Commit 4f594ef3 authored by Boris Pek's avatar Boris Pek

compat level and debhelper version were decreased to 8

to support Ubuntu Oneiric.
parent 53e3b62e
......@@ -3,7 +3,7 @@ Section: kde
Priority: optional
Maintainer: Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
Uploaders: Boris Pek <tehnick-8@mail.ru>
Build-Depends: debhelper (>= 9), dpkg-dev (>= 1.16.1~), cmake,
Build-Depends: debhelper (>= 8), cmake,
kdelibs5-dev, pkg-kde-tools, libgtk2.0-dev, libgtk-3-dev
Homepage: https://projects.kde.org/projects/playground/base/kde-gtk-config
Vcs-Git: git://github.com/tehnick/kde-gtk-config-debian.git
......
#!/usr/bin/make -f
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
CFLAGS+=$(CPPFLAGS)
CXXFLAGS+=$(CPPFLAGS)
CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
CFLAGS:=$(shell dpkg-buildflags --get CFLAGS) $(CPPFLAGS)
CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS) $(CPPFLAGS)
LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS) -Wl,--as-needed
export CPPFLAGS CFLAGS CXXFLAGS LDFLAGS
%:
dh $@ --parallel
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment