...
 
Commits (5)
knights (18.11.80-0r1) UNRELEASED; urgency=medium
[ Pino Toscano ]
* New upstream development release:
* New upstream development release: (Closes: #874962) (LP: #1757703)
- now part of KDE Applications, so adopt its versioning
* Switch Vcs-* fields to salsa.debian.org.
* Remove knights-dbg in favour of the -dbgsym package
......@@ -30,8 +30,12 @@ knights (18.11.80-0r1) UNRELEASED; urgency=medium
- bump the pkg-kde-tools build dependency to >= 0.15.16
* Switch cmake parameter BIN_INSTALL_DIR to KDE_INSTALL_BINDIR, as the former
is deprecated.
* Switch the Homepage to kde.org.
* Switch Maintainer to Debian Qt/KDE Maintainers.
* Bump the cmake build dependency to >= 3.2.0, as indicated by the upstream
build system.
-- Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org> Fri, 23 Nov 2018 20:44:09 +0100
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Fri, 23 Nov 2018 20:44:09 +0100
knights (2.5.0-2) unstable; urgency=medium
......
Source: knights
Section: games
Priority: optional
Maintainer: Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Uploaders: José Manuel Santamaría Lema <panfaust@gmail.com>
Build-Depends: debhelper (>= 11~), pkg-kde-tools (>= 0.15.16), cmake,
Build-Depends: debhelper (>= 11~), pkg-kde-tools (>= 0.15.16), cmake (>= 3.2.0),
extra-cmake-modules (>= 5.30.0~),
qtbase5-dev (>= 5.7.0~),
libqt5svg5-dev (>= 5.7.0~),
......@@ -20,7 +20,7 @@ Build-Depends: debhelper (>= 11~), pkg-kde-tools (>= 0.15.16), cmake,
libkf5wallet-dev (>= 5.30.0~),
libkf5kdegames-dev,
Standards-Version: 4.2.1
Homepage: http://kde-apps.org/content/show.php/Knights?content=122046
Homepage: https://www.kde.org/applications/games/knights/
Vcs-Browser: https://salsa.debian.org/qt-kde-team/kde/knights
Vcs-Git: https://salsa.debian.org/qt-kde-team/kde/knights.git
......
......@@ -9,4 +9,4 @@ override_dh_auto_configure:
dh_auto_configure -- -DKDE_INSTALL_BINDIR=/usr/games
override_dh_strip:
dh_strip --dbgsym-migration='knights-dbg (<< 2.5.0-3~)'
dh_strip --dbgsym-migration='knights-dbg (<< 18.11.80~)'