...
 
Commits (14)
syndication (18.08.1-1) UNRELEASED; urgency=medium
[ Sandro Knauß ]
* Bump Standards-Version to 4.2.1 (No changes needed).
* Follow stable releases in KDE again..
* New upstream release (18.08.1).
* Update build-deps and deps with the info from cmake.
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Thu, 13 Sep 2018 12:45:28 +0200
syndication (18.07.90-1) experimental; urgency=medium
* Team upload.
[ Sandro Knauß ]
* Update watch file to match unstable releases, too.
* New upstream release (18.07.90).
* Bump Standards-Version to 4.2.0 (No changes needed).
* Update build-deps and deps with the info from cmake
* Update symbols from build for 18.07.90.
* Remove not needed build dependency libkf5kio-dev.
* Use DebianABIManager to handle libkf5syndication5 properly.
* Update library from libkf5syndication5 -> libkf5syndication5abi1,
because of ABI breakage.
-- Sandro Knauß <hefee@debian.org> Thu, 16 Aug 2018 11:01:50 +0200
syndication (17.12.3-1) unstable; urgency=medium
* Team upload.
......
......@@ -5,12 +5,11 @@ Maintainer: Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Uploaders: Maximiliano Curia <maxy@debian.org>
Build-Depends: cmake (>= 3.0~),
debhelper (>= 11),
extra-cmake-modules (>= 5.39.0~),
libkf5codecs-dev (>= 5.39.0~),
libkf5kio-dev (>= 5.39.0~),
extra-cmake-modules (>= 5.47.0~),
libkf5codecs-dev (>= 5.47.0~),
pkg-kde-tools (>> 0.15.15),
qtbase5-dev,
Standards-Version: 4.1.3
qtbase5-dev (>= 5.9.1~),
Standards-Version: 4.2.1
Homepage: https://projects.kde.org/projects/kde/pim/syndication
Vcs-Browser: https://salsa.debian.org/qt-kde-team/kde/syndication
Vcs-Git: https://salsa.debian.org/qt-kde-team/kde/syndication.git
......@@ -19,7 +18,9 @@ Package: libkf5syndication-dev
Section: libdevel
Architecture: any
Multi-Arch: same
Depends: libkf5syndication5 (= ${binary:Version}), qtbase5-dev, ${misc:Depends}
Depends: libkf5syndication5abi1 (= ${binary:Version}),
qtbase5-dev (>= 5.9.1~),
${misc:Depends},
Description: parser library for RSS and Atom feeds - development files
Syndication is a parser library for RSS and Atom feeds. It offers a unified,
format-agnostic view on the parsed feed, so that the using application does
......@@ -28,7 +29,9 @@ Description: parser library for RSS and Atom feeds - development files
This package contains the development files.
Breaks: libkf5blog-dev (<< 4:17.08)
Package: libkf5syndication5
Package: libkf5syndication5abi1
X-Debian-ABI: 1
X-CMake-Target: KF5Syndication
Architecture: any
Multi-Arch: same
Depends: ${misc:Depends}, ${shlibs:Depends}
......
......@@ -288,6 +288,9 @@ License: CC-BY-NC-SA-2.5
shall not be bound by any additional provisions that may appear in any
communication from You. This License may not be modified without the mutual
written agreement of the Licensor and You.
.
You find the complete text of this copyright under:
https://creativecommons.org/licenses/by/2.5/legalcode
License: GPL-2+
This program is free software; you can redistribute it and/or modify
......
usr/lib/*/libKF5Syndication.so.5
usr/lib/*/libKF5Syndication.so.5.*
This diff is collapsed.
usr/lib/*/libKF5Syndication.so.5*
This diff is collapsed.
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,3 +73,5 @@ install(FILES
)
feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
+
+include(/usr/share/pkg-kde-tools/cmake/DebianABIManager.cmake)
enable_debianabimanager.diff