Add support for LXDE.

parent fd61b1f6
......@@ -2,6 +2,7 @@ qt4-x11 (4:4.8.7+dfsg-9) UNRELEASED; urgency=medium
[ Lisandro Damián Nicanor Pérez Meyer ]
* Update symbols files with buildds' logs.
* Add support for LXDE (Closes: #836894).
-- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> Fri, 09 Sep 2016 08:13:56 -0300
......
Description: Add support for LXDE desktop
This patch checks for an environment variable set by LXDE desktop, in order to
make Qt4 applications natively use the GTK+ style when run on this desktop
Author: Raphaël Halimi <raphael.halimi@gmail.com>
Origin: other
Last-Update: 2016-09-06
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/src/gui/kernel/qapplication_x11.cpp
+++ b/src/gui/kernel/qapplication_x11.cpp
@@ -2355,6 +2355,11 @@
break;
}
+ if (qgetenv("DESKTOP_SESSION") == "LXDE") {
+ X11->desktopEnvironment = DE_GNOME;
+ break;
+ }
+
// GNOME_DESKTOP_SESSION_ID is deprecated for some reason, but still check it
if (!qgetenv("GNOME_DESKTOP_SESSION_ID").isEmpty()) {
X11->desktopEnvironment = DE_GNOME;
\ No newline at end of file
......@@ -62,3 +62,4 @@ x32.diff
no-ssl3.patch
qt-everywhere-opensource-src-4.8.7-gcc6.patch
add-mate-support.patch
add-lxde-support.patch
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment