...
 
Commits (2)
  • Adam Majer's avatar
    Update clang dependecy to 6.0 · 5bde58c9
    Adam Majer authored
    We don't need to use conditional detection of clang path
    since we know what it is. Otherwise we could stop building
    clang code model by accident.
    
    Code model should still be hardcoded as API changes in clang
    could result in plugin from not building anymore.
    5bde58c9
  • Adam Majer's avatar
    Release to unstable · 4a9c6a3a
    Adam Majer authored
    4a9c6a3a
qtcreator (4.5.2-3) unstable; urgency=medium
* Update libclang dependency to 6.0 (closes: #893402)
-- Adam Majer <adamm@zombino.com> Sun, 18 Mar 2018 19:10:54 +0100
qtcreator (4.5.2-2) unstable; urgency=medium
* Team upload.
......
......@@ -8,14 +8,14 @@ Uploaders: Adam Majer <adamm@zombino.com>,
Simon Quigley <tsimonq2@ubuntu.com>
Build-Depends: debhelper (>= 11),
libbotan-2-dev,
libclang-3.9-dev [amd64 i386],
libclang-6.0-dev [amd64 i386],
libicu-dev,
libjs-jquery,
libqt5opengl5-dev (>= 5.6.2~),
libqt5sql5-sqlite (>= 5.6.2~),
libqt5webkit5-dev (>= 5.6.2~),
libqt5x11extras5-dev (>= 5.6.2~),
llvm-3.9-dev [amd64 i386],
llvm-6.0-dev [amd64 i386],
pkg-config,
qbs-dev (>= 1.10~),
qml-module-qtquick-controls (>= 5.6.2~),
......
......@@ -15,7 +15,7 @@ export QMAKE_CXXFLAGS_DEBUG := $(CXXFLAGS)
export QMAKE_LFLAGS_RELEASE := $(LDFLAGS)
export QMAKE_LFLAGS_DEBUG := $(LDFLAGS)
export QT_SELECT := qt5
export LLVM_INSTALL_DIR := $(shell if [ -d /usr/lib/llvm-3.9 ]; then echo /usr/lib/llvm-3.9; fi)
export LLVM_INSTALL_DIR := "/usr/lib/llvm-6.0"
# Upstream changelog
upstream_changes := $(wildcard dist/changes-*)
......