Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
diffoscope
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Reproducible Builds
diffoscope
Commits
041ad950
Commit
041ad950
authored
8 years ago
by
Chris Lamb
Browse files
Options
Downloads
Patches
Plain Diff
Rename diffoscope.__main__ to diffoscope.main as its not a "real" magic name
parent
5fb78d03
No related branches found
No related tags found
Loading
Changes
4
Hide whitespace changes
Inline
Side-by-side
Showing
4 changed files
bin/diffoscope
+1
-1
1 addition, 1 deletion
bin/diffoscope
diffoscope/main.py
+0
-0
0 additions, 0 deletions
diffoscope/main.py
setup.py
+1
-1
1 addition, 1 deletion
setup.py
tests/test_main.py
+1
-1
1 addition, 1 deletion
tests/test_main.py
with
3 additions
and
3 deletions
bin/diffoscope
+
1
−
1
View file @
041ad950
...
...
@@ -26,7 +26,7 @@ for root in ['.', '..']:
sys
.
path
=
[
root
]
+
sys
.
path
break
from
diffoscope.
__
main
__
import
main
from
diffoscope.main
import
main
if
__name__
==
'
__main__
'
:
main
()
This diff is collapsed.
Click to expand it.
diffoscope/
__
main
__
.py
→
diffoscope/main.py
+
0
−
0
View file @
041ad950
File moved
This diff is collapsed.
Click to expand it.
setup.py
+
1
−
1
View file @
041ad950
...
...
@@ -34,7 +34,7 @@ setup(name='diffoscope',
cmdclass
=
{
'
test
'
:
PyTest
},
entry_points
=
{
'
console_scripts
'
:
[
'
diffoscope=diffoscope.
__
main
__
:main
'
'
diffoscope=diffoscope.main:main
'
],
},
install_requires
=
[
...
...
This diff is collapsed.
Click to expand it.
tests/test_main.py
+
1
−
1
View file @
041ad950
...
...
@@ -21,7 +21,7 @@ import os
import
signal
import
tempfile
import
pytest
from
diffoscope.
__
main
__
import
main
from
diffoscope.main
import
main
def
test_non_existing_files
(
capsys
):
args
=
'
/nonexisting1 /nonexisting2
'
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment