Commit 8f983042 authored by Mattia Rizzolo's avatar Mattia Rizzolo

tests/comparators: dtb: compatibility with version 1.4.5

Used to be:

% fdtdump --version
Version: DTC 1.4.2-dirty
%

Now it's instead:

% fdtdump --version

**** fdtdump is a low-level debugging tool, not meant for general use.
**** If you want to decompile a dtb, you probably want
****     dtc -I dtb -O dts <filename>

Version: DTC 1.4.5
%

So the tests broke… (even worse, the whole testsuite broke as pytest
couldn't compute the list of tests to execute…)
Signed-off-by: Mattia Rizzolo's avatarMattia Rizzolo <mattia@debian.org>
parent 7ab62a0e
......@@ -36,7 +36,13 @@ dtb2 = load_fixture('devicetree2.dtb')
def fdtdump_version():
out = subprocess.check_output(('fdtdump', '--version'), stderr=subprocess.STDOUT)
return out.decode().split()[2]
# We are looking for a line like
# Version: DTC 1.4.5
# that usually is placed last
for line in reversed(out.decode().splitlines())):
if line.startswith('Version: '):
return line.split()[2]
raise ValueError('Error parsing `fdtdump --version` output')
def test_identification(dtb1):
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment