Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
diffoscope
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Reproducible Builds
diffoscope
Commits
e41abe00
Commit
e41abe00
authored
7 years ago
by
Chris Lamb
Browse files
Options
Downloads
Patches
Plain Diff
Move DOS/MBR check into the testsuite.
parent
d64ce7e7
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
debian/rules
+0
-3
0 additions, 3 deletions
debian/rules
tests/test_source.py
+30
-0
30 additions, 0 deletions
tests/test_source.py
with
30 additions
and
3 deletions
debian/rules
+
0
−
3
View file @
e41abe00
...
...
@@ -41,9 +41,6 @@ debian/diffoscope.bash-completion:
register-python-argcomplete diffoscope > $@
override_dh_auto_build: debian/diffoscope.bash-completion
@# Let's avoid plonking everything in the "DOS/MBR" category, this is really not
@# a sustainable filetype testing solution (e.g. c051ba9d and c1442405).
! grep 'DOS/MBR' -R diffoscope
dh_auto_build -O--buildsystem=pybuild
dh_auto_build -O--buildsystem=makefile -Ddoc
...
...
This diff is collapsed.
Click to expand it.
tests/test_source.py
0 → 100644
+
30
−
0
View file @
e41abe00
# -*- coding: utf-8 -*-
#
# diffoscope: in-depth comparison of files, archives, and directories
#
# Copyright © 2018 Chris Lamb <lamby@debian.org>
#
# diffoscope is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation, either version 3 of the License, or
# (at your option) any later version.
#
# diffoscope is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with diffoscope. If not, see <https://www.gnu.org/licenses/>.
import
os
import
glob
import
pytest
import
diffoscope
BASE_DIR
=
os
.
path
.
dirname
(
os
.
path
.
abspath
(
diffoscope
.
__file__
))
def
test_dos_mbr
():
for
x
in
glob
.
iglob
(
os
.
path
.
join
(
BASE_DIR
,
'
**
'
,
'
*.py
'
),
recursive
=
True
):
assert
'
DOS/MBR
'
not
in
open
(
x
).
read
()
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment