Imported Upstream version 0.5.0~git.20141112.b4a24bd49e

parent 0430a562

Too many changes to show.

To preserve performance only 1000 of 1000+ files are displayed.

#trademark sillyness
app/views/home/_show.*
app/views/terms/terms.*
app/assets/images/custom/
......@@ -9,6 +10,7 @@ config/heroku.yml
config/initializers/secret_token.rb
config/redis.conf
config/deploy_config.yml
config/schedule.rb
.bundle
vendor/bundle/
vendor/cache/
......@@ -28,9 +30,6 @@ spec/fixtures/*.y*ml
spec/fixtures/*.fixture.*
coverage/
xml_locales/
app/assets/images/branding-*.png
app/assets/images/icons-*.png
app/assets/images/social_media_logos-*.png
#Documentation
.yardoc/
......@@ -57,7 +56,6 @@ tmp/
*.swp
*~
*#
bin/*
nbproject
patches-*
capybara-*.html
......@@ -65,3 +63,9 @@ dump.rdb
#Rubinius's JIT
*.rbc
#IDE
diaspora.iml
# Dolphin's directory's preferences files
*.directory
#!/bin/sh
rvm rvmrc warning ignore
. ./script/env/ruby_env
if [ -e '.rvmrc.local' ]; then
. ./.rvmrc.local;
elif [ -e '.rvmrc_custom' ] ; then
. ./.rvmrc_custom;
else
if rvm list strings | grep -q "$ruby_version" ; then
rvm --create use "$ruby_version@$gemset"
else
printf "\e[00;31mPLEASE INSTALL RUBY $ruby_version WITH \`rvm install $ruby_version\`\n"
printf "Don't forget to run \`cd .. && cd -\` afterwards!\e[00m\n"
return 1
fi
fi
. ./script/env/ensure_right_rubygems
......@@ -5,8 +5,8 @@ branches:
language: ruby
rvm:
- 2.0.0
- 1.9.3
- 2.1
- 2.0
env:
- DB=postgres BUILD_TYPE=other
......@@ -16,12 +16,8 @@ env:
bundler_args: "--without development production heroku"
before_install: "./script/ci/before_install.sh"
script: "./script/ci/build.sh"
addons:
firefox: "26.0"
notifications:
irc:
channels:
......
This diff is collapsed.
source 'https://rubygems.org'
source 'https://rails-assets.org'
gem 'rails', '3.2.17'
gem 'rails', '4.1.7'
# Legacy Rails features, remove me!
# caches_page
gem 'actionpack-action_caching'
gem 'actionpack-page_caching'
# Appserver
gem 'unicorn', '4.8.0', :require => false
gem 'unicorn', '4.8.3', :require => false
# API and JSON
......@@ -13,140 +20,153 @@ gem 'json', '1.8.1'
# Authentication
gem 'devise', '3.2.2'
gem 'devise', '3.4.1'
gem 'devise_lastseenable', '0.0.4'
# Captcha
gem 'galetahub-simple_captcha', '0.1.5', :require => 'simple_captcha'
gem 'simple_captcha2', '0.3.2', :require => 'simple_captcha'
# Background processing
gem 'sidekiq', '2.17.2'
gem 'sidekiq', '3.2.5'
gem 'sinatra', '1.3.3'
# Scheduled processing
gem 'sidetiq', '0.6.3'
# Compression
gem 'uglifier', '2.5.3'
# Configuration
gem 'configurate', '0.0.8'
gem 'configurate', '0.2.0'
# Cross-origin resource sharing
gem 'rack-cors', '0.2.8', :require => 'rack/cors'
gem 'rack-cors', '0.2.9', :require => 'rack/cors'
# CSS
gem 'bootstrap-sass', '2.3.2.2'
gem 'compass-rails', '2.0.0'
gem 'sass-rails', '4.0.4'
# Database
ENV['DB'] ||= 'mysql'
gem 'mysql2', '0.3.14' if ENV['DB'] == 'all' || ENV['DB'] == 'mysql'
gem 'mysql2', '0.3.16' if ENV['DB'] == 'all' || ENV['DB'] == 'mysql'
gem 'pg', '0.17.1' if ENV['DB'] == 'all' || ENV['DB'] == 'postgres'
gem 'activerecord-import', '0.3.1'
gem 'activerecord-import', '0.6.0'
gem 'foreigner', '1.6.1'
# File uploading
gem 'carrierwave', '0.9.0'
gem 'fog', '1.19.0'
gem 'mini_magick', '3.7.0'
gem 'carrierwave', '0.10.0'
gem 'fog', '1.24.0'
gem 'mini_magick', '3.8.1'
gem 'remotipart', '1.2.1'
# GUID generation
gem 'uuid', '2.3.7'
# Icons
gem 'entypo-rails', '2.2.2'
# JavaScript
gem 'backbone-on-rails', '1.1.2'
gem 'handlebars_assets', '0.18.0'
gem 'jquery-rails', '3.1.2'
gem 'rails-assets-jquery', '1.11.1' # Should be kept in sync with jquery-rails
gem 'js_image_paths', '0.0.1'
gem 'js-routes', '0.9.9'
gem 'rails-assets-punycode', '1.3.2'
# jQuery plugins
gem 'rails-assets-jeresig--jquery.hotkeys', '0.2.0'
gem 'rails-assets-jquery-idletimer', '1.0.1'
gem 'rails-assets-jquery-placeholder', '2.0.8'
gem 'rails-assets-jquery-textchange', '0.2.3'
gem 'rails-assets-perfect-scrollbar', '0.5.7'
# Localization
gem 'http_accept_language', '1.0.2'
gem 'http_accept_language', '2.0.2'
gem 'i18n-inflector-rails', '1.0.7'
gem 'rails-i18n', '0.7.4'
gem 'rails-i18n', '4.0.3'
# Mail
gem 'markerb', '1.0.1'
gem 'markerb', '1.0.2'
gem 'messagebus_ruby_api', '1.0.3'
# Parsing
gem 'nokogiri', '1.6.1'
gem 'rails_autolink', '1.1.5'
gem 'redcarpet', '3.0.0'
gem 'nokogiri', '1.6.4.1'
gem 'redcarpet', '3.2.0'
gem 'twitter-text', '1.10.0'
gem 'roxml', '3.1.6'
gem 'ruby-oembed', '0.8.9'
gem 'ruby-oembed', '0.8.11'
gem 'opengraph_parser', '0.2.3'
# Please remove when migrating to Rails 4
gem 'strong_parameters'
# Services
gem 'omniauth', '1.1.4'
gem 'omniauth', '1.2.2'
gem 'omniauth-facebook', '1.6.0'
gem 'omniauth-tumblr', '1.1'
gem 'omniauth-twitter', '1.0.1'
gem 'twitter', '4.8.1'
gem 'omniauth-wordpress','0.2.0'
gem 'omniauth-wordpress','0.2.1'
# Tags
gem 'acts-as-taggable-on', '2.4.1'
gem 'acts-as-taggable-on', '3.4.2'
# URIs and HTTP
gem 'addressable', '2.3.5', :require => 'addressable/uri'
gem 'faraday', '0.8.9'
gem 'faraday_middleware', '0.9.0'
gem 'typhoeus', '0.6.7'
gem 'addressable', '2.3.6', :require => 'addressable/uri'
gem 'faraday', '0.9.0'
gem 'faraday_middleware', '0.9.1'
gem 'typhoeus', '0.6.9'
# Views
gem 'client_side_validations', '3.2.6'
gem 'gon', '4.1.1'