Commit 70c829df authored by Carlos Sanchez's avatar Carlos Sanchez

Issue #228 Add more docs on ruby 1.9 requirement in 1.1

parent f1accead
## Changelog
# Changelog
## 1.1.x: Requires Ruby >= 1.9, uses Puppet Forge API v3
### 1.1.2
......@@ -16,6 +18,8 @@
* Accesing the v3 API requires Ruby 1.9 due to the puppet_forge library used
## 1.0.x: Works on Ruby 1.8, using Puppet Forge API v1
### 1.0.4
* [Issue #231](https://github.com/rodjek/librarian-puppet/issues/231) Only use the GITHUB_API_TOKEN if it's not empty
......
......@@ -28,6 +28,13 @@ It is based on [Librarian](https://github.com/applicationsonline/librarian), a
framework for writing bundlers, which are tools that resolve, fetch, install,
and isolate a project's dependencies.
## Versions
Librarian-puppet >= 1.1.0 requires Ruby 1.9 and uses the Puppet Forge API v3.
Versions < 1.1.0 works on Ruby 1.8.
See the [Changelog](Changelog.md) for more details.
## The Puppetfile
Every Puppet repository that uses Librarian-puppet will have a file named
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment