From 8505db0f42dfcd744b45aa5327e3cc020741cf4e Mon Sep 17 00:00:00 2001
From: Daniel Leidert <dleidert@debian.org>
Date: Fri, 10 Apr 2020 23:52:53 +0200
Subject: [PATCH] Remove empty directory

  * d/rules: Delete empty directories in the package.
---
 debian/changelog | 1 +
 debian/rules     | 4 ++++
 2 files changed, 5 insertions(+)

diff --git a/debian/changelog b/debian/changelog
index a0255ee..3305e20 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -22,6 +22,7 @@ ruby-bert (1.1.6-2) unstable; urgency=medium
   * d/ruby-test-files.yaml: Replace by d/ruby-tests.rake.
   * d/ruby-tests.rake: Add file.
   * d/rules: Check dependencies on build and use gem installation layout.
+    Delete empty directories in the package.
   * d/patches/0001-Fix-test-includes-for-Ruby-2.1.patch: Rename to
     d/patches/0001-Fix-test-autorun.patch.
     - Replace load by require, remove LOAD_PATH changes, require autorunner.
diff --git a/debian/rules b/debian/rules
index f5d44c6..3cb7ce4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,3 +16,7 @@ export DH_RUBY = --gem-install
 
 %:
 	dh $@ --buildsystem=ruby --with ruby
+
+override_dh_install:
+	dh_install
+	find $(CURDIR)/debian/ruby-bert/usr/lib/ -type d -empty -delete
-- 
GitLab