Commit 095c5356 authored by Ryan Niebur's avatar Ryan Niebur

Imported Debian version 0.3.6+nmu1

parent a489f68a
dpkg-ruby (0.3.6+nmu1) unstable; urgency=high
* Non-maintainer upload.
* Use StringValuePtr instead of the long-deprecated (and removed in ruby
1.9.1) STR2CSTR (closes: #593025).
-- Julien Cristau <jcristau@debian.org> Thu, 26 Aug 2010 17:43:59 +0200
dpkg-ruby (0.3.6) unstable; urgency=low
* switch to ruby 1.9.1 (Closes: #565848)
......
......@@ -6,8 +6,8 @@ using namespace std;
extern "C" {
static VALUE cmp_version(VALUE self, VALUE anObject, VALUE cmpType, VALUE anOtherObject) {
int res = debVS.CmpVersion(STR2CSTR(anObject),STR2CSTR(anOtherObject));
char * cmp = STR2CSTR(cmpType);
int res = debVS.CmpVersion(StringValuePtr(anObject),StringValuePtr(anOtherObject));
char * cmp = StringValuePtr(cmpType);
if(!strcmp(cmp, "lt") || !strcmp(cmp, "<") || !strcmp(cmp, "<<")) {
if(res < 0)
return Qtrue;
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment