Commit 804bafc3 authored by Ryan Niebur's avatar Ryan Niebur

switch to ruby 1.9.1 (Closes: #565848)

parent 17a9cc78
dpkg-ruby (0.3.6) UNRELEASED; urgency=low
* switch to ruby 1.9.1 (Closes: #565848)
-- Ryan Niebur <ryan@debian.org> Fri, 29 Jan 2010 23:16:17 -0800
dpkg-ruby (0.3.5) unstable; urgency=low
* fix some file leaks (Closes: #564117)
......
......@@ -2,7 +2,7 @@ Source: dpkg-ruby
Section: devel
Priority: optional
Maintainer: Ryan Niebur <ryan@debian.org>
Build-Depends: debhelper (>= 7.0.50~), ruby1.8, ruby1.8-dev, libapt-pkg-dev, ruby1.9, ruby1.9-dev, ruby
Build-Depends: debhelper (>= 7.0.50~), ruby1.8, ruby1.8-dev, libapt-pkg-dev, ruby1.9.1, ruby1.9.1-dev, ruby
Vcs-Git: git://git.debian.org/apt-listbugs/dpkg-ruby.git
Vcs-Browser: http://git.debian.org/?p=apt-listbugs/dpkg-ruby.git;a=summary
Standards-Version: 3.8.3
......@@ -35,7 +35,7 @@ Description: modules/classes for dpkg on ruby 1.8
Debian::Deb, Debian::Dsc, Debian::Archives, Debian::Sources,
Debian::Packages and Debian::Status classes on ruby 1.8.
Package: libdpkg-ruby1.9
Package: libdpkg-ruby1.9.1
Section: ruby
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}
......
......@@ -11,7 +11,7 @@ EXAMPLES=debian/libdpkg-ruby1.8.examples
%:
dh $@
VERSION_1.9=1.9
VERSION_1.9=1.9.1
19VERSION=$(shell ruby$(VERSION_1.9) -rrbconfig -e 'puts Config::CONFIG["ruby_version"]')
override_dh_auto_build:
......@@ -27,7 +27,7 @@ override_dh_auto_build:
override_dh_auto_clean:
$(MAKE) clean RUBY=$(RUBY)
rm -f $(EXAMPLES)
for i in install docs examples; do rm -f debian/libdpkg-ruby1.9.$$i; done
for i in install docs examples; do rm -f debian/libdpkg-ruby$(VERSION_1.9).$$i; done
[ ! -f ext/ruby1.8/Makefile ] || make -C ext/ruby1.8 distclean
[ ! -f ext/ruby1.9/Makefile ] || make -C ext/ruby1.9 distclean
......@@ -48,7 +48,7 @@ override_dh_auto_install:
echo bin/dpkg.rb >> $(EXAMPLES)
override_dh_install:
for i in install docs examples; do cp debian/libdpkg-ruby1.8.$$i debian/libdpkg-ruby1.9.$$i; sed -i s/1.8/$(19VERSION)/g debian/libdpkg-ruby1.9.$$i; done
for i in install docs examples; do cp debian/libdpkg-ruby1.8.$$i debian/libdpkg-ruby$(VERSION_1.9).$$i; sed -i s/1.8/$(19VERSION)/g debian/libdpkg-ruby$(VERSION_1.9).$$i; done
dh_install --sourcedir=$(CURDIR)/debian/tmp
override_dh_auto_test:
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment