...
 
Commits (6)
  • Jérémy Bobbio's avatar
  • Jérémy Bobbio's avatar
    42a861dd
  • Jérémy Bobbio's avatar
    Merge tag 'debian/3.0.2-2' into wheezy-backports · a629ac24
    Jérémy Bobbio authored
    Format: 1.8
    Date: Sat, 19 Oct 2013 14:58:05 +0200
    Source: ruby-gettext
    Binary: ruby-gettext
    Architecture: source all
    Version: 3.0.2-2
    Distribution: unstable
    Urgency: low
    Maintainer: Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
    Changed-By: Jérémy Bobbio's avatarJérémy Bobbio <lunar@debian.org>
    Description:
     ruby-gettext - gettext for Ruby
    Closes: 726797
    Changes:
     ruby-gettext (3.0.2-2) unstable; urgency=low
     .
       [ Jérémy Bobbio ]
       * Team upload.
       * Add a patch to fix rxgettext. (Closes: #726797)
     .
       [ Hleb Valoshka ]
       * Remove no more required lintian-overrides.
       * Fix manpage.
    Checksums-Sha1:
     3253b3b32a37dfb744945d6b7be0377d00ac32f1 1252 ruby-gettext_3.0.2-2.dsc
     378e6c167b777862f5c0827fcc3c739fad170c2a 15617 ruby-gettext_3.0.2-2.debian.tar.gz
     bbb5de5ced37df1d8e0f0a2218d2f9b0d7018de2 116476 ruby-gettext_3.0.2-2_all.deb
    Checksums-Sha256:
     097e0e2841a268190f4ce361145313fc8392055c41225c6705335529a7beeaaa 1252 ruby-gettext_3.0.2-2.dsc
     4d21613728aaca78af290204a4fb0300435c23496051301380bd2333bc28d825 15617 ruby-gettext_3.0.2-2.debian.tar.gz
     54d565011e1d1dceeaab1a273190bf7bd74bd7e63345ec345c073ec5caf146fa 116476 ruby-gettext_3.0.2-2_all.deb
    Files:
     565060a4a4426a008b24793db92c261a 1252 ruby optional ruby-gettext_3.0.2-2.dsc
     36a90157b63d7cd0b0f1a1a61247f7de 15617 ruby optional ruby-gettext_3.0.2-2.debian.tar.gz
     d0017c9530636afb810f1c3930f6cf4b 116476 ruby optional ruby-gettext_3.0.2-2_all.deb
    a629ac24
  • Jérémy Bobbio's avatar
    Disable unsupported Ruby 1.8 · 0bf446c4
    Jérémy Bobbio authored
    0bf446c4
  • Jérémy Bobbio's avatar
    4dc3aef0
  • Jérémy Bobbio's avatar
    8a73eb26
ruby-gettext (3.0.2-2~bpo70+1) wheezy-backports; urgency=low
* Rebuild for wheezy-backports:
- Disable unsupported Ruby 1.8.
- Add a patch to xplicitly use ruby1.9.1 for scripts.
-- Jérémy Bobbio <lunar@debian.org> Tue, 17 Dec 2013 16:50:21 +0100
ruby-gettext (3.0.2-2) unstable; urgency=low
[ Jérémy Bobbio ]
......@@ -49,6 +57,12 @@ ruby-gettext (3.0.0-1) unstable; urgency=low
-- Jérémy Bobbio <lunar@debian.org> Sun, 01 Sep 2013 19:09:40 +0200
ruby-gettext (2.3.9-1~bpo70+1) wheezy-backports; urgency=low
* Rebuild for wheezy-backports.
-- Jérémy Bobbio <lunar@debian.org> Tue, 09 Jul 2013 12:17:48 +0200
ruby-gettext (2.3.9-1) unstable; urgency=low
* Team upload.
......
......@@ -17,12 +17,12 @@ Standards-Version: 3.9.4
Vcs-Git: git://anonscm.debian.org/pkg-ruby-extras/ruby-gettext.git
Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-ruby-extras/ruby-gettext.git;a=summary
Homepage: http://ruby-gettext.github.io/
XS-Ruby-Versions: all
XS-Ruby-Versions: ruby1.9.1
Package: ruby-gettext
Architecture: all
XB-Ruby-Versions: ${ruby:Versions}
Depends: ruby | ruby-interpreter,
Depends: ruby1.9.1,
ruby-locale (>= 2.0.5),
ruby-text,
${misc:Depends},
......
[DEFAULT]
pristine-tar = True
debian-branch = wheezy-backports
From 4264d91a4cd6e746c10d2fd9151dbc0da277313c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?J=C3=A9r=C3=A9my=20Bobbio?= <lunar@debian.org>
Date: Tue, 17 Dec 2013 16:48:20 +0100
Subject: [PATCH] Explicitly use ruby1.9.1 for scripts
---
bin/rmsgfmt | 2 +-
bin/rmsginit | 2 +-
bin/rmsgmerge | 2 +-
bin/rxgettext | 2 +-
4 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/bin/rmsgfmt b/bin/rmsgfmt
index f2336ca..449b09a 100755
--- a/bin/rmsgfmt
+++ b/bin/rmsgfmt
@@ -1,4 +1,4 @@
-#! /usr/bin/env ruby
+#! /usr/bin/env ruby1.9.1
# -*- coding: utf-8 -*-
#
# Copyright (C) 2012 Kouhei Sutou <kou@clear-code.com>
diff --git a/bin/rmsginit b/bin/rmsginit
index 99c8e14..468e6a0 100755
--- a/bin/rmsginit
+++ b/bin/rmsginit
@@ -1,4 +1,4 @@
-#! /usr/bin/env ruby
+#! /usr/bin/env ruby1.9.1
# -*- coding: utf-8 -*-
#
# Copyright (C) 2012 Kouhei Sutou <kou@clear-code.com>
diff --git a/bin/rmsgmerge b/bin/rmsgmerge
index 438d893..8a8b317 100755
--- a/bin/rmsgmerge
+++ b/bin/rmsgmerge
@@ -1,4 +1,4 @@
-#! /usr/bin/env ruby
+#! /usr/bin/env ruby1.9.1
# -*- coding: utf-8 -*-
#
# Copyright (C) 2012 Kouhei Sutou <kou@clear-code.com>
diff --git a/bin/rxgettext b/bin/rxgettext
index dd7122a..85016fa 100755
--- a/bin/rxgettext
+++ b/bin/rxgettext
@@ -1,4 +1,4 @@
-#! /usr/bin/env ruby
+#! /usr/bin/env ruby1.9.1
# -*- coding: utf-8 -*-
#
# Copyright (C) 2012 Kouhei Sutou <kou@clear-code.com>
--
1.7.10.4
......@@ -4,3 +4,4 @@
0004-Use-system-racc-in-Rakefile.patch
0005-Restore-compatibility-with-Ruby-1.8.patch
0006-Add-missing-require-in-lib-gettext-tools-xgettext.rb.patch
0007-Explicitly-use-ruby1.9.1-for-scripts.patch