jekyll-feed.gemspec 1.08 KB
Newer Older
1 2 3 4 5
# frozen_string_literal: true

lib = File.expand_path("lib", __dir__)
$LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
require "jekyll-feed/version"
6 7 8

Gem::Specification.new do |spec|
  spec.name          = "jekyll-feed"
9
  spec.version       = Jekyll::Feed::VERSION
10 11 12 13 14 15 16
  spec.authors       = ["Ben Balter"]
  spec.email         = ["ben.balter@github.com"]
  spec.summary       = "A Jekyll plugin to generate an Atom feed of your Jekyll posts"
  spec.homepage      = "https://github.com/jekyll/jekyll-feed"
  spec.license       = "MIT"

  spec.files         = `git ls-files -z`.split("\x0")
17
  spec.test_files    = spec.files.grep(%r!^spec/!)
18 19
  spec.require_paths = ["lib"]

20
  spec.required_ruby_version = ">= 2.3.0"
21

22 23 24
  spec.add_dependency "jekyll", ">= 3.7", "< 5.0"

  spec.add_development_dependency "bundler"
25 26
  spec.add_development_dependency "nokogiri", "~> 1.6"
  spec.add_development_dependency "rake", "~> 12.0"
27
  spec.add_development_dependency "rspec", "~> 3.0"
28 29
  spec.add_development_dependency "rubocop-jekyll", "~> 0.5"
  spec.add_development_dependency "typhoeus", ">= 0.7", "< 2.0"
30
end