Imported Upstream version 0.0.6

parent e16a74fa
# Version 0.0.6
* Use 'name' from Azure for name, and 'unique_name' for nickname per Auth Hash spec. Thanks @jayme-github
# Version 0.0.5
* loosen jwt requirement
# Version 0.0.5
* loosen jwt requirement
# VERSION 0.0.4
* fix for JWT scoping, thanks @tobsher
......
module OmniAuth
module AzureOauth2
VERSION = "0.0.5"
VERSION = "0.0.6"
end
end
......@@ -42,7 +42,8 @@ module OmniAuth
info do
{
name: raw_info['unique_name'],
name: raw_info['name'],
nickname: raw_info['unique_name'],
first_name: raw_info['given_name'],
last_name: raw_info['family_name'],
email: raw_info['email'] || raw_info['upn'],
......
--- !ruby/object:Gem::Specification
name: omniauth-azure-oauth2
version: !ruby/object:Gem::Version
version: 0.0.5
platform: ruby
authors:
- Mark Nadig
autorequire:
bindir: bin
cert_chain: []
date: 2015-03-30 00:00:00.000000000 Z
dependencies:
- !ruby/object:Gem::Dependency
name: omniauth
requirement: !ruby/object:Gem::Requirement
requirements:
- - ~>
- !ruby/object:Gem::Version
version: '1.0'
type: :runtime
prerelease: false
version_requirements: !ruby/object:Gem::Requirement
requirements:
- - ~>
- !ruby/object:Gem::Version
version: '1.0'
- !ruby/object:Gem::Dependency
name: jwt
requirement: !ruby/object:Gem::Requirement
requirements:
- - ~>
- !ruby/object:Gem::Version
version: '1.0'
type: :runtime
prerelease: false
version_requirements: !ruby/object:Gem::Requirement
requirements:
- - ~>
- !ruby/object:Gem::Version
version: '1.0'
- !ruby/object:Gem::Dependency
name: omniauth-oauth2
requirement: !ruby/object:Gem::Requirement
requirements:
- - ~>
- !ruby/object:Gem::Version
version: '1.1'
type: :runtime
prerelease: false
version_requirements: !ruby/object:Gem::Requirement
requirements:
- - ~>
- !ruby/object:Gem::Version
version: '1.1'
- !ruby/object:Gem::Dependency
name: rspec
requirement: !ruby/object:Gem::Requirement
requirements:
- - '>='
- !ruby/object:Gem::Version
version: 2.14.0
type: :development
prerelease: false
version_requirements: !ruby/object:Gem::Requirement
requirements:
- - '>='
- !ruby/object:Gem::Version
version: 2.14.0
- !ruby/object:Gem::Dependency
name: rake
requirement: !ruby/object:Gem::Requirement
requirements:
- - '>='
- !ruby/object:Gem::Version
version: '0'
type: :development
prerelease: false
version_requirements: !ruby/object:Gem::Requirement
requirements:
- - '>='
- !ruby/object:Gem::Version
version: '0'
description: An Windows Azure Active Directory OAuth2 strategy for OmniAuth
email:
- mark@nadigs.net
executables: []
extensions: []
extra_rdoc_files: []
files:
- .gitignore
- CHANGELOG.md
- Gemfile
- LICENSE
- README.md
- Rakefile
- examples/sinatra.rb
- lib/omniauth-azure-oauth2.rb
- lib/omniauth/azure_oauth2.rb
- lib/omniauth/azure_oauth2/version.rb
- lib/omniauth/strategies/azure_oauth2.rb
- omniauth-azure-oauth2.gemspec
- spec/omniauth/strategies/azure_oauth2_spec.rb
- spec/spec_helper.rb
homepage: https://github.com/KonaTeam/omniauth-azure-oauth2
licenses:
- MIT
metadata: {}
post_install_message:
rdoc_options: []
require_paths:
- lib
required_ruby_version: !ruby/object:Gem::Requirement
requirements:
- - '>='
- !ruby/object:Gem::Version
version: '0'
required_rubygems_version: !ruby/object:Gem::Requirement
requirements:
- - '>='
- !ruby/object:Gem::Version
version: '0'
requirements: []
rubyforge_project:
rubygems_version: 2.4.5
signing_key:
specification_version: 4
summary: An Windows Azure Active Directory OAuth2 strategy for OmniAuth
test_files: []
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment