Commit f5938c8d authored by Jerome Benoit's avatar Jerome Benoit

Imported Debian patch 0.999c+ds-1 (ABI update)

parent d1dd6395
......@@ -2,11 +2,14 @@ apophenia (0.999c+ds-1) unstable; urgency=medium
* New upstream version (Closes: #764904).
* Debianization:
- debian/control, update;
- debian/repack, refresh;
- debian/patches/upstream-wipeout-exit.patch, remove as it has been
integrated by the upstream author.
integrated by the upstream author;
- debian/patches/upstream-update-library_version.patch, implement
(and submit to the upstream maintainer).
-- Jerome Benoit <calculus@rezozer.net> Wed, 10 Dec 2014 19:55:14 +0000
-- Jerome Benoit <calculus@rezozer.net> Tue, 16 Dec 2014 14:22:09 +0000
apophenia (0.999b+ds3-2) unstable; urgency=medium
......
......@@ -17,7 +17,7 @@ Homepage: http://apophenia.info/
Vcs-Git: git://anonscm.debian.org/debian-science/packages/apophenia.git
Vcs-Browser: http://anonscm.debian.org/gitweb/?p=debian-science/packages/apophenia.git
Package: libapophenia0
Package: libapophenia1
Provides: libapophenia
Section: libs
Architecture: any
......@@ -45,13 +45,13 @@ Description: Apophenia Statistical C Library -- library package
.
This package provides the shared libraries required to run programs
compiled against the Apophenia Statistical C Library. To compile your
own programs you also need to install the libapophenia0-dev package.
own programs you also need to install the libapophenia1-dev package.
Package: libapophenia0-dev
Package: libapophenia1-dev
Provides: libapophenia-dev
Section: libdevel
Architecture: any
Depends: libapophenia0 (= ${binary:Version}), ${misc:Depends}
Depends: libapophenia1 (= ${binary:Version}), ${misc:Depends}
Conflicts: libapophenia-dev
Suggests: pkg-config
Multi-Arch: same
......@@ -78,7 +78,7 @@ Description: Apophenia Statistical C Library -- development package
Package: apophenia-bin
Architecture: any
Depends: libapophenia0 (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
Depends: libapophenia1 (= ${binary:Version}), ${shlibs:Depends}, ${misc:Depends}
Suggests: sqlite3
Multi-Arch: foreign
Description: Apophenia Statistical C Library -- binary package
......@@ -100,12 +100,12 @@ Description: Apophenia Statistical C Library -- binary package
.
This package provides several command line utility examples.
Package: libapophenia0-dbg
Package: libapophenia1-dbg
Provides: libapophenia-dbg
Section: debug
Priority: extra
Architecture: any
Depends: libapophenia0 (= ${binary:Version}), ${misc:Depends}
Depends: libapophenia1 (= ${binary:Version}), ${misc:Depends}
Conflicts: libapophenia-dbg
Multi-Arch: same
Description: Apophenia Statistical C Library -- debug symbols package
......@@ -126,14 +126,14 @@ Description: Apophenia Statistical C Library -- debug symbols package
GNU General Public License version 2 (GPL2) with two modifications.
.
This package provides the debugging symbols for the libraries from
the libapophenia0-dev package.
the libapophenia1-dev package.
Package: apophenia-doc
Section: doc
Architecture: all
Depends: ${misc:Depends}
Suggests:
libapophenia0 (= ${binary:Version}), libapophenia0-dev (= ${binary:Version}),
libapophenia1 (= ${binary:Version}), libapophenia1-dev (= ${binary:Version}),
# pdf-viewer,
www-browser,
gsl-doc-pdf, gsl-ref-html
......
This diff is collapsed.
This diff is collapsed.
upstream-update-libtool.patch
upstream-update-library_version.patch
upstream-update-docs_doxygen_conf_in.patch
debianization.patch
debianization-help2man.patch
......
Description: update library version
Update the library version wrt to the Libtool Manual (section 7.3)
and the related material; meant to be submitted to the upstream maintainer.
Origin: debian
Author: Jerome Benoit <calculus@rezozer.net>
Last-Update: 2014-12-16
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,9 @@
AM_CFLAGS = -g -Wall -O3
## Library versioning (C:R:A == current:revision:age)
-LIBAPOPHENIA_LT_VERSION = 0:0:0
+## 0.999b 0:0:0
+## 0.999c 1:0:0
+LIBAPOPHENIA_LT_VERSION = 1:0:0
SUBDIRS = transform model . cmd tests docs eg
--- a/apophenia.map
+++ b/apophenia.map
@@ -1,4 +1,4 @@
-LIBAPOPHENIA_0.0.0 {
+LIBAPOPHENIA_1.0.0 {
global:
apop_opts;
apop_name_alloc;
......@@ -33,7 +33,7 @@ ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
endif
override_dh_strip:
dh_strip --dbg-package=libapophenia0-dbg
dh_strip --dbg-package=libapophenia1-dbg
get-orig-source:
uscan --no-conf --download-current-version --verbose
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment