Commit 5b17f0f3 authored by Julian Taylor's avatar Julian Taylor

move wisdom tools to libfftw3-bin, make libfftw3-dev multiarch same

parent 3317b337
...@@ -2,8 +2,9 @@ fftw3 (3.3.1-5) unstable; urgency=low ...@@ -2,8 +2,9 @@ fftw3 (3.3.1-5) unstable; urgency=low
* Team upload. * Team upload.
* enable avx on i386 too * enable avx on i386 too
* move wisdom tools to libfftw3-bin, make libfftw3-dev multiarch same
-- Julian Taylor <jtaylor.debian@googlemail.com> Sun, 22 Apr 2012 14:24:03 +0200 -- Julian Taylor <jtaylor.debian@googlemail.com> Sun, 22 Apr 2012 14:30:52 +0200
fftw3 (3.3.1-4) experimental; urgency=low fftw3 (3.3.1-4) experimental; urgency=low
......
...@@ -19,7 +19,7 @@ Package: libfftw3-3 ...@@ -19,7 +19,7 @@ Package: libfftw3-3
Architecture: any Architecture: any
Pre-Depends: multiarch-support Pre-Depends: multiarch-support
Depends: ${misc:Depends}, ${shlibs:Depends} Depends: ${misc:Depends}, ${shlibs:Depends}
Suggests: libfftw3-dev, libfftw3-mt3 (>= 3.3.1-4) Suggests: libfftw3-dev, libfftw3-bin, libfftw3-mt3 (>= 3.3.1-4)
Provides: fftw3 Provides: fftw3
Replaces: fftw3 Replaces: fftw3
Conflicts: fftw3 Conflicts: fftw3
...@@ -34,6 +34,19 @@ Description: Library for computing Fast Fourier Transforms ...@@ -34,6 +34,19 @@ Description: Library for computing Fast Fourier Transforms
To get the static library and the header files, you need to install To get the static library and the header files, you need to install
libfftw3-dev. For documentation, see libfftw3-doc. libfftw3-dev. For documentation, see libfftw3-doc.
Package: libfftw3-bin
Architecture: any
Depends: ${misc:Depends}, ${shlibs:Depends}
Multi-Arch: foreign
Description: Library for computing Fast Fourier Transforms - Tools
The FFTW library computes Fast Fourier Transforms (FFT) in one or more
dimensions. It is extremely fast. This package contains the shared library
versions of the fftw libraries in single, double and long double precisions.
Note that on some architectures double is the same as long double in which
case there is no long double library.
.
This package contains the wisdom management tools.
Package: libfftw3-mt3 Package: libfftw3-mt3
Architecture: any Architecture: any
Pre-Depends: multiarch-support Pre-Depends: multiarch-support
...@@ -74,10 +87,15 @@ Description: MPI Library for computing Fast Fourier Transforms ...@@ -74,10 +87,15 @@ Description: MPI Library for computing Fast Fourier Transforms
Package: libfftw3-dev Package: libfftw3-dev
Architecture: any Architecture: any
Section: libdevel Section: libdevel
Depends: libfftw3-3 (=${binary:Version}), ${misc:Depends}, ${shlibs:Depends} Depends: libfftw3-3 (=${binary:Version}),
libfftw3-bin (=${binary:Version}),
libfftw3-mt3 (=${binary:Version}),
${misc:Depends},
${shlibs:Depends}
Provides: fftw3-dev Provides: fftw3-dev
Replaces: fftw3-dev Replaces: fftw3-dev
Conflicts: fftw3-dev Conflicts: fftw3-dev
Multi-Arch: same
Description: Library for computing Fast Fourier Transforms - development Description: Library for computing Fast Fourier Transforms - development
The FFTW library computes Fast Fourier Transforms (FFT) in one or more The FFTW library computes Fast Fourier Transforms (FFT) in one or more
dimensions. It is extremely fast. This package contains the statically linked dimensions. It is extremely fast. This package contains the statically linked
......
usr/bin/fftw*-wisdom*
usr/bin/fftw*-wisdom*
usr/include/* usr/include/*
usr/lib/*/libfftw*.a usr/lib/*/libfftw*.a
usr/lib/*/libfftw*.so usr/lib/*/libfftw*.so
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment