Commit 0dfa1560 authored by Alastair McKinstry's avatar Alastair McKinstry

Fix alternatives. Closes: #729212.

parent e1fb0746
flexpart (9.02-10) UNRELEASED; urgency=medium
flexpart (9.02-10) unstable; urgency=medium
* Build with -mcmodel=large on arm74, ppc64el. Closes: #767213.
* Move to Standards-Version: 3.9.6
* Add Vcs-Git to debian/control. Point to debian-science.
* Patch from Andreas Beckmann:
* postinst: Do not run update-alternatives --auto as that would override
local customization.
* prerm: Remove the correct alternative. (Closes: #729212)
-- Alastair McKinstry <mckinstry@debian.org> Tue, 07 Jul 2015 07:36:54 +0100
-- Alastair McKinstry <mckinstry@debian.org> Tue, 07 Jul 2015 07:59:02 +0100
flexpart (9.02-9) unstable; urgency=medium
......
......@@ -8,7 +8,6 @@ case "$1" in
configure|abort-remove|abort-deconfigure)
# Install alternatives
update-alternatives --install /usr/bin/flexpart flexpart /usr/bin/flexpart.ecmwf 20
update-alternatives --auto flexpart
;;
abort-upgrade)
# Nothing to undo
......
......@@ -6,6 +6,6 @@ set -e
if [ "$1" != "upgrade" ]
then
update-alternatives --remove-all flexpart
update-alternatives --remove flexpart /usr/bin/flexpart.ecmwf
fi
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment