changelog 8.09 KB
Newer Older
1
grads (3:2.2.1-1) unstable; urgency=medium
2 3

  * New upstream release
4
    - geotiff-fix.patch now upstream
5
  * Standards-Version: 4.1.5
6
  * Depend on libgadap-dev >= 2.0-11 for fPIC build
7

8
 -- Alastair McKinstry <mckinstry@debian.org>  Tue, 17 Jul 2018 09:45:02 +0100
9

Alastair McKinstry's avatar
Alastair McKinstry committed
10
grads (3:2.2.0-2) unstable; urgency=medium
Alastair McKinstry's avatar
Alastair McKinstry committed
11

12 13
  * Drop obsolete B-D on dpkg-dev (was needed for M-A)
  * Standards-Version: 4.1.3
14
  * Move VCS to salsa.debian.org
15 16
  * Drop obsolete call to autoreconf
  * Provide /usr/share/grads/udpt file
Alastair McKinstry's avatar
Alastair McKinstry committed
17

Alastair McKinstry's avatar
Alastair McKinstry committed
18
 -- Alastair McKinstry <mckinstry@debian.org>  Thu, 15 Feb 2018 10:47:03 +0000
Alastair McKinstry's avatar
Alastair McKinstry committed
19

20
grads (3:2.2.0-1) unstable; urgency=medium
21 22

  * New upstream release
23
  * Patch needed to pass geotiff_inc 
24
  * Drop redundant Build-Depends on auto*
25
  * Standards-Version: 4.1.1. No changes required
26
  * Relax version dependency on libsx-dev
27
  * Drop build-dependency on transitional libhdf5-serial-dev. 
28
    Closes: #879138, #740013
29
  * Patch needed to build: remove static on gcmn.
30
  * Include favicon.png rather than read remotely: privacy breach
31

32
 -- Alastair McKinstry <mckinstry@debian.org>  Fri, 20 Oct 2017 09:38:05 +0100
33

34
grads (3:2.1.1.b0-1) unstable; urgency=medium
35 36

  * New upstream release
37
    - build against libdap3.19, libsx2.09
38
  * B-D on libssl-dev now needed
39
  * Standards-Version: 4.0.0; no changes required
40
  * Change to match overrides: from science-extra to utils-optional
41

42
 -- Alastair McKinstry <mckinstry@debian.org>  Fri, 14 Jul 2017 07:16:38 +0100
43

44 45 46 47 48 49
grads (3:2.1.0-2) unstable; urgency=medium

  * Add Desktop file and icon

 -- Alastair McKinstry <mckinstry@debian.org>  Sat, 24 Dec 2016 17:39:31 +0000

Alastair McKinstry's avatar
Alastair McKinstry committed
50
grads (3:2.1.0-1) unstable; urgency=medium
Alastair McKinstry's avatar
Alastair McKinstry committed
51

Alastair McKinstry's avatar
Alastair McKinstry committed
52
  * New upstream release
53 54
  * Update home page
  * Depend on libgadap >= 2.0-7 for -fPIC. Closes: #841493.
Alastair McKinstry's avatar
Alastair McKinstry committed
55

Alastair McKinstry's avatar
Alastair McKinstry committed
56
 -- Alastair McKinstry <mckinstry@debian.org>  Fri, 21 Oct 2016 22:02:16 +0100
Alastair McKinstry's avatar
Alastair McKinstry committed
57

58 59 60 61
grads (2:2.1.a3-4) unstable; urgency=medium

  * Rebuild against libgadap-dev >= 2.0-6 for libdap 3.18.0 compatability
    Closes: #836338
Alastair McKinstry's avatar
Alastair McKinstry committed
62
  * DH_COMPAT=10
63 64 65

 -- Alastair McKinstry <mckinstry@debian.org>  Sun, 04 Sep 2016 09:15:13 +0100

66 67 68 69 70 71
grads (2:2.1.a3-3) unstable; urgency=medium

  * Drop kernel name from configure, for reproducible builds

 -- Alastair McKinstry <mckinstry@debian.org>  Sat, 09 Jul 2016 12:10:36 +0100

72
grads (2:2.1.a3-2) unstable; urgency=medium
73 74

  * Remove unnecessary dependencies on openjpeg, libpng. Closes: #826815
75
  * Add debian/gpb.conf file
76

77
 -- Alastair McKinstry <mckinstry@debian.org>  Sat, 11 Jun 2016 08:52:20 +0100
78

79
grads (2:2.1.a3-1) unstable; urgency=medium
80 81

  * Standards-Version: 3.9.8
82
  * Add data, examples tarballs
83 84
  * Depend on libgrib2c-dev >= 1.6.0-3 to remove Jasper. Closes: #818214.
  * Depend on libpng-dev >= 1.6.21; png16 transition done.
85
  * Enable png16 patch, look for it, not png15
86
  * Patch to use NC_CONFIG in /usr/bin
87

Alastair McKinstry's avatar
Alastair McKinstry committed
88
 -- Alastair McKinstry <mckinstry@debian.org>  Tue, 24 May 2016 14:13:26 +0100
89

90
grads (2:2.1~a3-1) experimental; urgency=medium
91

92
  * New upstream release.
93 94
  * B-D on libaec-dev, remove libsz-not-present patch as libaec provides
    libsz
Alastair McKinstry's avatar
Alastair McKinstry committed
95 96 97
  * Build against libcairo2-dev, libpng-dev for new UX
  * Drop libjasper in favour of libopenjpeg.
  * Standards-Version: 3.9.7. No changes required. 
98

99
 -- Alastair McKinstry <mckinstry@debian.org>  Thu, 07 Apr 2016 09:47:30 +0100
100

101
grads (2:2.0.2-7.1) unstable; urgency=medium
102

103 104
  * Non-maintainer upload.
  * Rebuild with libnetcdf 4.4.0~rc2 for netcdf transition.
105

106 107 108 109 110 111 112 113 114 115 116 117 118
 -- Bas Couwenberg <sebastic@debian.org>  Mon, 24 Aug 2015 13:52:00 +0200

grads (2:2.0.2-7) unstable; urgency=medium

  * test Build against hdf5 1.8.15 

 -- Alastair McKinstry <mckinstry@debian.org>  Sun, 16 Aug 2015 03:58:23 +0100

grads (2:2.0.2-6) unstable; urgency=medium

  * Build against libdap for g++5 transition

 -- Alastair McKinstry <mckinstry@debian.org>  Sat, 15 Aug 2015 07:24:33 +0100
119

Alastair McKinstry's avatar
Alastair McKinstry committed
120
grads (2:2.0.2-5) unstable; urgency=medium
121 122 123

  * Change libgd2-xpm-dev -> libgd-dev. 

124
 -- Alastair McKinstry <mckinstry@debian.org>  Tue, 07 Jul 2015 01:17:12 +0100
125

126 127 128 129 130 131 132 133 134 135
grads (2:2.0.2-4) unstable; urgency=medium

  * Build against libdap 3.14.0 for transition.
  * Remove build_date from config scripts to make build bit-reproducible.
  * Move to Standards-Version: 3.9.6
  * Add Vcs-Git pointing to git repo in debian-science. 
  * Require libsx-dev >> 2.05-7

 -- Alastair McKinstry <mckinstry@debian.org>  Mon, 06 Jul 2015 11:28:06 +0100

136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252
grads (2:2.0.2-3) unstable; urgency=low

  [ Gilles Filippini ]
  * Support hdf5 1.8.13 new packaging layout.  Closes: #756666.

 -- Alastair McKinstry <mckinstry@debian.org>  Fri, 01 Aug 2014 16:36:33 +0100

grads (2:2.0.2-2) unstable; urgency=medium

  * Remove hard-coded references to 2.0.1 files.

 -- Alastair McKinstry <mckinstry@debian.org>  Tue, 17 Jun 2014 09:43:48 +0100

grads (2:2.0.2-1) unstable; urgency=medium

  * New upstream release.

 -- Alastair McKinstry <mckinstry@debian.org>  Tue, 17 Jun 2014 07:39:22 +0100

grads (2:2.0.1-2) unstable; urgency=medium

  * Move to debhelper 9
  * Now at Standards-Version: 3.9.5 
  * Change to Priority: extra because we depend on hdf4-alt, etc.

 -- Alastair McKinstry <mckinstry@debian.org>  Wed, 26 Feb 2014 09:30:59 +0000

grads (2:2.0.1-1) unstable; urgency=low

  * New upstream build.
  * Build against libhdf4-alt-dev. Closes: #655869.
  * Now use gadap for in-situ data. 
  * Now at Standards-Version: 3.9.3
  * New epoch needed as 2.0.1 < 2.0.a9. 

 -- Alastair McKinstry <mckinstry@debian.org>  Wed, 19 Sep 2012 15:25:13 +0100

grads (2.0.a9-4) unstable; urgency=low

  * B-D on dh-autoreconf; use dh -- with autoreconf 

 -- Alastair McKinstry <mckinstry@debian.org>  Sun, 23 Oct 2011 21:53:28 +0100

grads (2.0.a9-3) unstable; urgency=low

  * B-D on netcdf-bin for nc-config, or ./configure may behave differently.
  * Enable  --enable-dyn-supplibs for dynamic linking. 
  * Enable --with-hdf4-include to find HDF4 ; patch needed to compile.
  * Patch for format-security error. Closes: #646268.
  * Autogenerated gunk breaks building from source. Fix. Closes: #643144.
  * Remove debian-changes-* patches; 

 -- Alastair McKinstry <mckinstry@debian.org>  Sun, 23 Oct 2011 17:54:31 +0100

grads (2.0.a9-2) unstable; urgency=low

  * Build with libhdf5-dev | libhdf5-serial-dev. Closes: #634524.
  * Build MPI version if DEB_BUILD_OPTIONS=mpi
  * Add --with-dap as libdap is now in Debian. 

 -- Alastair McKinstry <mckinstry@debian.org>  Sat, 10 Sep 2011 11:53:29 +0100

grads (2.0.a9-1) unstable; urgency=low

  * New upstream release.
  * Now at Standards-Version: 3.9.2.
  * Fix by Steve Langasek to avoid hard-coded /usr/lib paths; 
    for multilib. Closes: #622320.
  * Include libshp-dev for shapefile support in new version. 
  * Include patch from Nicolai Strange fixing netcdf time units parse bug.
    Closes: #587496. 

 -- Alastair McKinstry <mckinstry@debian.org>  Tue, 12 Apr 2011 14:31:38 +0100

grads (2.0.a8-2) unstable; urgency=low

  * Add libgd2-xpm-dev to Build-Depends to build the grib2scan and gxtran
    binaries (Closes: #608584). Thanks to Salvatore Bonaccorso.
  * Move to Standards-Version: 3.9.1. No changes required. 

 -- Alastair McKinstry <mckinstry@debian.org>  Sun, 02 Jan 2011 02:16:47 +0000

grads (2.0.a8-1) unstable; urgency=low

  * New upstream release. 
  * Add SUPPLIBS to environment to add netcdf, geotiff properly.
  * Enabled HDF5, netCDF-4, geotiff properly; disabled netCDF-4 
    Closes: #571048.

 -- Alastair McKinstry <mckinstry@debian.org>  Sun, 09 May 2010 14:11:05 +0100

grads (2.0.a7.1-4) unstable; urgency=low

  * Move to Source format 3.0. Remove dep. on quilt.
  * Standards-Version: 3.8.4. No changes required. 
  * Add DEP-3 tags to patches.

 -- Alastair McKinstry <mckinstry@debian.org>  Fri, 26 Feb 2010 16:47:44 +0000

grads (2.0.a7.1-3) unstable; urgency=low

  * Add Build-Depends: linxmu-headers. Closes: #551446.
  * Change section to Science.

 -- Alastair McKinstry <mckinstry@debian.org>  Mon, 19 Oct 2009 17:40:59 +0100

grads (2.0.a7.1-2) unstable; urgency=low

  * Add Build-Depends: libx11-dev. Closes: #550307. 

 -- Alastair McKinstry <mckinstry@debian.org>  Tue, 13 Oct 2009 15:48:08 +0100

grads (2.0.a7.1-1) unstable; urgency=low

  * Initial release. (Closes: #540545)

 -- Alastair McKinstry <mckinstry@debian.org>  Sun, 04 Oct 2009 12:38:20 +0100