.travis.yml 435 Bytes
Newer Older
1 2 3 4
language: python
python:
  - "2.6"
  - "2.7"
5
  - "3.4"
6 7 8
# command to install dependencies
install:
# develop seems to be required by travis since 02/2013
9
  - pip install PyYAML argparse rospkg vcstools catkin_pkg python-dateutil rosdistro
10 11 12 13 14 15 16
  - python setup.py build develop
  - pip install nose coverage
# command to run tests
script:
  - nosetests --with-coverage --cover-package=rosdep2 --with-xunit test
notifications:
  email: false