Commit 14120f5f authored by Anton Gladky's avatar Anton Gladky

Initialize GUI in IPython 5. (Closes: #856175)

parent 65755372
From: Anton Gladky <gladk@debian.org>
Date: Sat, 25 Feb 2017 22:30:24 +0100
Subject: [PATCH] Initialize gui in IPython 5.
---
core/main/main.py.in | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)
Index: yade/core/main/main.py.in
===================================================================
--- yade.orig/core/main/main.py.in
+++ yade/core/main/main.py.in
@@ -244,6 +244,9 @@ def userSession(gui='none',qapp=None):
InteractiveShellEmbed.config=cfg
InteractiveShellEmbed.banner1=banner+'\n'
ipshell=InteractiveShellEmbed()
+ # If IPython > 5 one need to initialize graphic gui
+ if ((gui == "qt5" or gui == "qt4")and yade.runtime.ipython_version>=500):
+ ipshell.enable_gui(gui)
ipshell()
## run userSession in a way corresponding to the features we use:
01_remove_google_analytics.patch
08_fix_gui.patch
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment