Commit b9312684 authored by Sergei Golovan's avatar Sergei Golovan Committed by Sergei Golovan

* Added conflicts header to the debian/control file which ensures that the

    no longer existing expectk package gets removed (closes: #686364).
  * Switched to 3.0 (quilt) source package format.
  * Bumped debhelper compatibility level to 8.
  * Bumped standards version to 3.9.4.
parent 2e6aee2b
This package uses quilt to manage all modifications to the upstream
source. Changes are stored in the source package as diffs in
debian/patches and applied during the build.
To get detailed instructions on how to apply the series of patches
and modify them, please read /usr/share/doc/quilt/README.source
-- Sergei Golovan <sgolovan@debian.org> Fri, 16 Oct 2009 22:39:58 +0400
......@@ -2,8 +2,11 @@ expect (5.45-3) unstable; urgency=low
* Added conflicts header to the debian/control file which ensures that the
no longer existing expectk package gets removed (closes: #686364).
* Switched to 3.0 (quilt) source package format.
* Bumped debhelper compatibility level to 8.
* Bumped standards version to 3.9.4.
-- Sergei Golovan <sgolovan@debian.org> Thu, 24 Jan 2013 11:26:45 +0400
-- Sergei Golovan <sgolovan@debian.org> Mon, 06 May 2013 13:08:02 +0400
expect (5.45-2) unstable; urgency=low
......
......@@ -2,10 +2,10 @@ Source: expect
Section: interpreters
Priority: optional
Maintainer: Sergei Golovan <sgolovan@debian.org>
Build-Depends: debhelper (>= 7.0.50~), quilt (>=0.46-7), autotools-dev, autoconf,
Build-Depends: debhelper (>= 8.0.0), autotools-dev, autoconf,
tcl8.5-dev
Build-Conflicts: autoconf2.13
Standards-Version: 3.9.2
Standards-Version: 3.9.4
Homepage: http://sourceforge.net/projects/expect/
Package: expect
......
#!/usr/bin/make -f
VERSION = 5.45
v = 5.45
SHELL := sh -e
%:
dh ${@} --with quilt
dh ${@}
CFLAGS = -Wall -g -D_BSD_SOURCE -ansi -D_SVID_SOURCE -D_POSIX_SOURCE
......@@ -35,7 +35,7 @@ override_dh_auto_configure:
CFLAGS="$(CFLAGS)"
override_dh_auto_build:
$(MAKE) SONAME=libexpect.so.$(VERSION)
$(MAKE) SONAME=libexpect.so.$(v)
override_dh_auto_install:
$(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
......@@ -51,16 +51,17 @@ override_dh_auto_install:
fi; \
done
# Fixing library name
mv debian/tmp/usr/lib/expect$(VERSION)/libexpect$(VERSION).so debian/tmp/usr/lib/libexpect.so.$(VERSION)
mv debian/tmp/usr/lib/expect$(v)/libexpect$(v).so debian/tmp/usr/lib/libexpect.so.$(v)
mkdir -p -m 755 debian/tmp/usr/lib/tcltk
mv debian/tmp/usr/lib/expect$(VERSION) debian/tmp/usr/lib/tcltk
mv debian/tmp/usr/lib/expect$(v) debian/tmp/usr/lib/tcltk
# Fixing permissions
chmod 0644 debian/tmp/usr/lib/tcltk/expect$(VERSION)/pkgIndex.tcl
chmod 0644 debian/tmp/usr/lib/tcltk/expect$(v)/pkgIndex.tcl
override_dh_install:
dh_install --fail-missing
get-orig-source:
wget -O expect_$(VERSION).orig.tar.gz \
http://downloads.sourceforge.net/project/expect/Expect/$(VERSION)/expect$(VERSION).tar.gz
wget -O expect_$(v).orig.tar.gz \
http://prdownloads.sourceforge.net/expect/expect$(v).tar.gz
.PHONY: override_dh_auto_clean override_dh_auto_configure override_dh_auto_build override_dh_auto_install override_dh_install get-orig-source
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment