Commit c6aca638 authored by Michael Biebl's avatar Michael Biebl

New upstream version 1.2.8

parent 5af0d03b
......@@ -727,7 +727,7 @@ distdir: $(DISTFILES)
! -type d ! -perm -444 -exec $(install_sh) -c -m a+r {} {} \; \
|| chmod -R a+r "$(distdir)"
dist-gzip: distdir
tardir=$(distdir) && $(am__tar) | GZIP=$(GZIP_ENV) gzip -c >$(distdir).tar.gz
tardir=$(distdir) && $(am__tar) | eval GZIP= gzip $(GZIP_ENV) -c >$(distdir).tar.gz
$(am__post_remove_distdir)
dist-bzip2: distdir
......@@ -752,7 +752,7 @@ dist-shar: distdir
@echo WARNING: "Support for shar distribution archives is" \
"deprecated." >&2
@echo WARNING: "It will be removed altogether in Automake 2.0" >&2
shar $(distdir) | GZIP=$(GZIP_ENV) gzip -c >$(distdir).shar.gz
shar $(distdir) | eval GZIP= gzip $(GZIP_ENV) -c >$(distdir).shar.gz
$(am__post_remove_distdir)
dist-zip: distdir
......@@ -770,7 +770,7 @@ dist dist-all:
distcheck: dist
case '$(DIST_ARCHIVES)' in \
*.tar.gz*) \
GZIP=$(GZIP_ENV) gzip -dc $(distdir).tar.gz | $(am__untar) ;;\
eval GZIP= gzip $(GZIP_ENV) -dc $(distdir).tar.gz | $(am__untar) ;;\
*.tar.bz2*) \
bzip2 -dc $(distdir).tar.bz2 | $(am__untar) ;;\
*.tar.lz*) \
......@@ -780,7 +780,7 @@ distcheck: dist
*.tar.Z*) \
uncompress -c $(distdir).tar.Z | $(am__untar) ;;\
*.shar.gz*) \
GZIP=$(GZIP_ENV) gzip -dc $(distdir).shar.gz | unshar ;;\
eval GZIP= gzip $(GZIP_ENV) -dc $(distdir).shar.gz | unshar ;;\
*.zip*) \
unzip $(distdir).zip ;;\
esac
......
=======================================================
NetworkManagerg-openvpn-1.2.8
Overview of changes since NetworkManager-openvpn-1.2.6
=======================================================
This is a new stable release of NetworkManager-openvpn. Notable changes include:
* Treat cipher and hmac options case insensitive in the properties GUI
* Support numeric argument to mssfix option
* Fixes to translatable strings and use Unicode
* Updated Czech, German, Hungarian, Polish, Spanish translations
=======================================================
NetworkManagerg-openvpn-1.2.6
Overview of changes since NetworkManager-openvpn-1.2.4
......
......@@ -491,7 +491,7 @@ AC_DEFUN([AM_NLS],
])
dnl pkg.m4 - Macros to locate and utilise pkg-config. -*- Autoconf -*-
dnl serial 11 (pkg-config-0.29)
dnl serial 11 (pkg-config-0.29.1)
dnl
dnl Copyright © 2004 Scott James Remnant <scott@netsplit.com>.
dnl Copyright © 2012-2015 Dan Nicholson <dbn.lists@gmail.com>
......@@ -533,7 +533,7 @@ dnl
dnl See the "Since" comment for each macro you use to see what version
dnl of the macros you require.
m4_defun([PKG_PREREQ],
[m4_define([PKG_MACROS_VERSION], [0.29])
[m4_define([PKG_MACROS_VERSION], [0.29.1])
m4_if(m4_version_compare(PKG_MACROS_VERSION, [$1]), -1,
[m4_fatal([pkg.m4 version $1 or higher is required but ]PKG_MACROS_VERSION[ found])])
])dnl PKG_PREREQ
......
......@@ -510,7 +510,7 @@ main (int argc, char *argv[])
*/
prompt = get_passwords_required (data, hints, &need_password, &need_certpass, &need_proxypass);
if (!prompt)
prompt = g_strdup_printf (_("You need to authenticate to access the Virtual Private Network '%s'."), vpn_name);
prompt = g_strdup_printf (_("You need to authenticate to access the Virtual Private Network “%s”."), vpn_name);
/* Exit early if we don't need any passwords */
if (!need_password && !need_certpass && !need_proxypass)
......
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
# Generated by GNU Autoconf 2.69 for NetworkManager-openvpn 1.2.6.
# Generated by GNU Autoconf 2.69 for NetworkManager-openvpn 1.2.8.
#
# Report bugs to <https://bugzilla.gnome.org/enter_bug.cgi?product=NetworkManager>.
#
......@@ -591,8 +591,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='NetworkManager-openvpn'
PACKAGE_TARNAME='NetworkManager-openvpn'
PACKAGE_VERSION='1.2.6'
PACKAGE_STRING='NetworkManager-openvpn 1.2.6'
PACKAGE_VERSION='1.2.8'
PACKAGE_STRING='NetworkManager-openvpn 1.2.8'
PACKAGE_BUGREPORT='https://bugzilla.gnome.org/enter_bug.cgi?product=NetworkManager'
PACKAGE_URL=''
......@@ -1414,7 +1414,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
\`configure' configures NetworkManager-openvpn 1.2.6 to adapt to many kinds of systems.
\`configure' configures NetworkManager-openvpn 1.2.8 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
......@@ -1485,7 +1485,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
short | recursive ) echo "Configuration of NetworkManager-openvpn 1.2.6:";;
short | recursive ) echo "Configuration of NetworkManager-openvpn 1.2.8:";;
esac
cat <<\_ACEOF
......@@ -1636,7 +1636,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
NetworkManager-openvpn configure 1.2.6
NetworkManager-openvpn configure 1.2.8
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
......@@ -2059,7 +2059,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
It was created by NetworkManager-openvpn $as_me 1.2.6, which was
It was created by NetworkManager-openvpn $as_me 1.2.8, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
......@@ -2922,7 +2922,7 @@ fi
# Define the identity of the package.
PACKAGE='NetworkManager-openvpn'
VERSION='1.2.6'
VERSION='1.2.8'
cat >>confdefs.h <<_ACEOF
......@@ -12577,7 +12577,7 @@ done
NM_GIT_SHA=46fc91035f8f4790d22bc2fb1be9c8cbbe04cf07
NM_GIT_SHA=3b19f480395aadf50de531d0a3df9bb8d924fe62
if test """" != "no-config-h" ; then
......@@ -15007,7 +15007,7 @@ rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
CFLAGS_MORE_WARNINGS="-Wall -std=gnu89"
CFLAGS_MORE_WARNINGS="-Wall -std=gnu99"
if test "x$set_more_warnings" = xerror; then
CFLAGS_MORE_WARNINGS="$CFLAGS_MORE_WARNINGS -Werror"
......@@ -15881,7 +15881,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
This file was extended by NetworkManager-openvpn $as_me 1.2.6, which was
This file was extended by NetworkManager-openvpn $as_me 1.2.8, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
......@@ -15947,7 +15947,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
NetworkManager-openvpn config.status 1.2.6
NetworkManager-openvpn config.status 1.2.8
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"
......
AC_PREREQ(2.52)
AC_INIT(NetworkManager-openvpn,
1.2.6,
1.2.8,
https://bugzilla.gnome.org/enter_bug.cgi?product=NetworkManager,
NetworkManager-openvpn)
AM_INIT_AUTOMAKE([1.9 tar-ustar no-dist-gzip dist-xz])
......@@ -117,7 +117,7 @@ LIBNM_CFLAGS="$LIBNM_CFLAGS -DNM_VERSION_MAX_ALLOWED=NM_VERSION_1_2"
NM_VPN_SERVICE_DIR=`$PKG_CONFIG --define-variable prefix='\${prefix}' --variable vpnservicedir libnm`
AC_SUBST(NM_VPN_SERVICE_DIR)
NM_COMPILER_WARNINGS
NM_COMPILER_WARNINGS([yes])
NM_PLUGIN_DIR="$libdir/NetworkManager"
AC_SUBST(NM_PLUGIN_DIR)
......
......@@ -37,7 +37,7 @@ AC_DEFUN([NM_COMPILER_WARNING], [
AC_DEFUN([NM_COMPILER_WARNINGS],
[AC_ARG_ENABLE(more-warnings,
AS_HELP_STRING([--enable-more-warnings], [Possible values: no/yes/error]),
set_more_warnings="$enableval",set_more_warnings=yes)
set_more_warnings="$enableval",set_more_warnings=$1)
AC_MSG_CHECKING(for more warnings)
if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
AC_MSG_RESULT(yes)
......@@ -55,7 +55,7 @@ if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
dnl attach it to the CFLAGS.
NM_COMPILER_WARNING([unknown-warning-option], [])
CFLAGS_MORE_WARNINGS="-Wall -std=gnu89"
CFLAGS_MORE_WARNINGS="-Wall -std=gnu99"
if test "x$set_more_warnings" = xerror; then
CFLAGS_MORE_WARNINGS="$CFLAGS_MORE_WARNINGS -Werror"
......
This diff is collapsed.
This diff is collapsed.
This diff is collapsed.
This diff is collapsed.
This diff is collapsed.
This diff is collapsed.
This diff is collapsed.
This diff is collapsed.
This diff is collapsed.
This diff is collapsed.
This diff is collapsed.
This diff is collapsed.
This diff is collapsed.
This diff is collapsed.
This diff is collapsed.
This diff is collapsed.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment