Commit 1c38a873 authored by Martin's avatar Martin

only build-depend on python3-distutils (#893694),

add patch to not use distutils during runtime
parent 71ccf86a
Pipeline #3386 failed with stages
in 11 seconds
......@@ -13,6 +13,7 @@ Build-Depends:
intltool (>= 0.40.1),
libglib2.0-dev,
python3,
python3-distutils,
python3-gi,
python3-gi-cairo,
gir1.2-gtk-3.0,
......@@ -27,10 +28,10 @@ Vcs-Browser: https://salsa.debian.org/xmpp-team/gajim
Package: gajim
Architecture: all
Depends:
${misc:Depends}, ${python3:Depends},
gir1.2-gtk-3.0,
${misc:Depends},
${python3:Depends},
gir1.2-gtk-3.0 (>= 3.20.0),
python3,
python3-distutils,
python3-gi,
python3-gi-cairo,
python3-idna,
......
Description: Remove unnecessary use of distutils
Author: W. Martin Borgert <debacle@debian.org>
Origin: vendor
Bug-Debian: https://bugs.debian.org/893694
Last-Update: 2018-03-25
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/gajim/gajim.py
+++ b/gajim/gajim.py
@@ -143,20 +143,6 @@
print('Gajim needs python-nbxmpp to run. Quitting…')
sys.exit(1)
- from distutils.version import LooseVersion as V
- if V(nbxmpp.__version__) < V(MIN_NBXMPP_VER):
- print('Gajim needs python-nbxmpp >= %s to run. '
- 'Quitting...' % MIN_NBXMPP_VER)
- sys.exit(1)
-
- gtk_ver = '%s.%s.%s' % (Gtk.get_major_version(),
- Gtk.get_minor_version(),
- Gtk.get_micro_version())
- if V(gtk_ver) < V(MIN_GTK_VER):
- print('Gajim needs GTK+ >= %s to run. '
- 'Quitting...' % MIN_GTK_VER)
- sys.exit(1)
-
# Create and initialize Application Paths & Databases
from gajim.common import configpaths
configpaths.gajimpaths.init(
--- a/gajim/common/app.py
+++ b/gajim/common/app.py
@@ -32,7 +32,6 @@
import logging
import locale
import uuid
-from distutils.version import LooseVersion as V
from collections import namedtuple
import gi
import nbxmpp
@@ -180,10 +179,6 @@
on a much lower version number than gnupg
Also we need at least python-gnupg 0.3.8
'''
- v_gnupg = gnupg.__version__
- if V(v_gnupg) < V('0.3.8') or V(v_gnupg) > V('1.0.0'):
- glog.info('Gajim needs python-gnupg >= 0.3.8')
- HAVE_GPG = False
except ImportError:
HAVE_GPG = False
else:
--- a/gajim/common/helpers.py
+++ b/gajim/common/helpers.py
@@ -44,7 +44,6 @@
import socket
import time
from datetime import datetime, timedelta, timezone, tzinfo
-from distutils.version import LooseVersion as V
from encodings.punycode import punycode_encode
from string import Template
@@ -1590,11 +1589,6 @@
return _get_img_proxy(attrs, proxy)
return _get_img_direct(attrs)
-def version_condition(current_version, required_version):
- if V(current_version) < V(required_version):
- return False
- return True
-
def get_available_emoticon_themes():
emoticons_themes = []
emoticons_data_path = os.path.join(app.DATA_DIR, 'emoticons')
--- a/gajim/common/connection.py
+++ b/gajim/common/connection.py
@@ -63,7 +63,6 @@
from gajim.common import exceptions
from gajim.common import check_X509
from gajim.common.connection_handlers import *
-from gajim.common.helpers import version_condition
from gajim.common.contacts import GC_Contact
from gajim.gtkgui_helpers import get_action
@@ -1219,12 +1218,8 @@
cipher_list = app.config.get_per('accounts', self.name,
'cipher_list')
- if version_condition(nbxmpp.__version__, '0.6.3'):
- secure_tuple = (self._current_type, cacerts, mycerts, tls_version,
- cipher_list, self._current_host['alpn'])
- else:
- secure_tuple = (self._current_type, cacerts, mycerts, tls_version,
- cipher_list)
+ secure_tuple = (self._current_type, cacerts, mycerts, tls_version,
+ cipher_list, self._current_host['alpn'])
con = nbxmpp.NonBlockingClient(
domain=self._hostname,
do-not-use-distutils.patch
no-git-call.patch
stop-loading-plugins.patch
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment