Commit 1f1a2dbc authored by Martin's avatar Martin

update patches for 1.1.0-beta2

parent 7ae506b1
......@@ -2,12 +2,12 @@ Description: Remove unnecessary use of distutils
Author: W. Martin Borgert <debacle@debian.org>
Origin: vendor
Bug-Debian: https://bugs.debian.org/893694
Last-Update: 2018-08-21
Last-Update: 2018-10-14
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/gajim/gajim.py
+++ b/gajim/gajim.py
@@ -24,7 +24,6 @@
@@ -22,7 +22,6 @@
import platform
from ctypes import CDLL, byref, create_string_buffer
from ctypes.util import find_library
......@@ -15,7 +15,7 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
# Install _() in namespace
from gajim.common import i18n
@@ -33,20 +32,6 @@
@@ -31,19 +30,6 @@
_MIN_GTK_VER = "3.22.0"
......@@ -26,7 +26,6 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
- print('Gajim needs python-nbxmpp to run. Quitting…')
- sys.exit(1)
-
- from distutils.version import LooseVersion as V
- if V(nbxmpp.__version__) < V(_MIN_NBXMPP_VER):
- print('Gajim needs python-nbxmpp >= %s to run. '
- 'Quitting...' % _MIN_NBXMPP_VER)
......@@ -36,7 +35,7 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
def _init_gui(gui):
if gui == 'GTK':
_init_gtk()
@@ -61,15 +46,6 @@
@@ -58,15 +44,6 @@
gi.require_version('GObject', '2.0')
gi.require_version('Pango', '1.0')
......@@ -52,7 +51,7 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
from gajim import gtkexcepthook
gtkexcepthook.init()
@@ -116,6 +92,5 @@
@@ -113,6 +90,5 @@
if os.geteuid() == 0:
sys.exit("You must not launch gajim as root, it is insecure.")
......@@ -61,18 +60,18 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
_init_gui('GTK')
--- a/gajim/common/app.py
+++ b/gajim/common/app.py
@@ -32,7 +32,6 @@
import sys
@@ -35,7 +35,6 @@
import logging
import uuid
from pathlib import Path
-from distutils.version import LooseVersion as V
from collections import namedtuple
import nbxmpp
@@ -201,10 +200,6 @@
on a much lower version number than gnupg
Also we need at least python-gnupg 0.3.8
'''
@@ -216,10 +215,6 @@
# We test with a version check if python-gnupg is installed as it is
# on a much lower version number than gnupg
# Also we need at least python-gnupg 0.3.8
- v_gnupg = gnupg.__version__
- if V(v_gnupg) < V('0.3.8') or V(v_gnupg) > V('1.0.0'):
- log('gajim').info('Gajim needs python-gnupg >= 0.3.8')
......@@ -82,15 +81,15 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
pass
--- a/gajim/common/helpers.py
+++ b/gajim/common/helpers.py
@@ -44,7 +44,6 @@
import socket
@@ -40,7 +40,6 @@
import time
import logging
from datetime import datetime, timedelta
-from distutils.version import LooseVersion as V
from encodings.punycode import punycode_encode
from string import Template
@@ -1472,11 +1471,6 @@
@@ -1449,11 +1448,6 @@
return _get_img_proxy(attrs, proxy)
return _get_img_direct(attrs)
......@@ -100,5 +99,5 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
- return True
-
def get_available_emoticon_themes():
emoticons_themes = []
if sys.platform not in ('win32', 'darwin'):
emoticons_themes = ['font']
files = []
......@@ -6,12 +6,7 @@ Last-Update: 2018-08-21
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/gajim/__init__.py
+++ b/gajim/__init__.py
@@ -1,17 +1,7 @@
import os
-import subprocess
__version__ = "1.0.99"
@@ -6,12 +6,3 @@
IS_FLATPAK = False
if os.path.exists('/app/share/run-as-flatpak'):
IS_FLATPAK = True
......
......@@ -6,7 +6,7 @@ Last-Update: 2018-08-21
--- a/gajim/gui_interface.py
+++ b/gajim/gui_interface.py
@@ -2618,7 +2618,7 @@
@@ -2610,7 +2610,7 @@
if not cfg_was_read:
# enable plugin_installer by default when creating config file
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment