Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
J
jabberd2
Manage
Activity
Members
Labels
Plan
Wiki
Code
Merge requests
1
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Debian XMPP Maintainers
jabberd2
Commits
c2d181c5
Commit
c2d181c5
authored
5 years ago
by
Sergei Golovan
Browse files
Options
Downloads
Patches
Plain Diff
Fix FTBFS with libmariadb 10.3.
parent
fe99f24a
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
debian/changelog
+7
-0
7 additions, 0 deletions
debian/changelog
debian/patches/mariadb10.3.diff
+48
-0
48 additions, 0 deletions
debian/patches/mariadb10.3.diff
debian/patches/series
+1
-0
1 addition, 0 deletions
debian/patches/series
with
56 additions
and
0 deletions
debian/changelog
+
7
−
0
View file @
c2d181c5
jabberd2 (2.6.1-4) unstable; urgency=medium
* Team upload.
* Fix FTBFS with libmariadb 10.3. Closes: #917758.
-- Sergei Golovan <sgolovan@debian.org> Tue, 29 Jan 2019 00:41:56 +0300
jabberd2 (2.6.1-3) unstable; urgency=medium
* Update Vcs-Browser and Vcs-Git URLs to salsa.
...
...
This diff is collapsed.
Click to expand it.
debian/patches/mariadb10.3.diff
0 → 100644
+
48
−
0
View file @
c2d181c5
Author: Sergei Golovan <sgolovan@debian.org>
Description: Patch fixes FTBFS with libmariadb 10.3 by using
proper call to mysql_options() instead of using an internal structure
which has been changed between 10.1 and 10.3.
The code is taken from the MySQL docs:
https://dev.mysql.com/doc/refman/5.7/en/c-api-auto-reconnect.html
Last-Modified: Tue, 29 Jan 2019 00:39:39 +0300
Debian-Bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=917758
Bug: https://github.com/jabberd2/jabberd2/issues/193
--- a/storage/authreg_mysql.c
+++ b/storage/authreg_mysql.c
@@ -487,6 +487,7 @@
MYSQL *conn;
mysqlcontext_t mysqlcontext;
int fail = 0;
+ my_bool reconnect = 1;
/* configure the database context with field names and SQL statements */
mysqlcontext = (mysqlcontext_t) malloc( sizeof( struct mysqlcontext_st ) );
@@ -628,7 +629,7 @@
mysql_query(conn, "SET NAMES 'utf8'");
/* Set reconnect flag to 1 (set to 0 by default from mysql 5 on) */
- conn->reconnect = 1;
+ mysql_options(conn, MYSQL_OPT_RECONNECT, &reconnect);
ar->user_exists = _ar_mysql_user_exists;
if (MPC_PLAIN == mysqlcontext->password_type) {
--- a/storage/storage_mysql.c
+++ b/storage/storage_mysql.c
@@ -584,6 +584,7 @@
const char *host, *port, *dbname, *user, *pass;
MYSQL *conn;
drvdata_t data;
+ my_bool reconnect = 1;
host = config_get_one(drv->st->config, "storage.mysql.host", 0);
port = config_get_one(drv->st->config, "storage.mysql.port", 0);
@@ -613,7 +614,7 @@
}
/* Set reconnect flag to 1 (set to 0 by default from mysql 5 on) */
- conn->reconnect = 1;
+ mysql_options(conn, MYSQL_OPT_RECONNECT, &reconnect);
data = (drvdata_t) calloc(1, sizeof(struct drvdata_st));
This diff is collapsed.
Click to expand it.
debian/patches/series
+
1
−
0
View file @
c2d181c5
...
...
@@ -8,3 +8,4 @@ systemd-alias.diff
systemd-bindsto.diff
m4-ax_check_compile_flag.diff
openssl11.diff
mariadb10.3.diff
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment