Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
B
blends
Manage
Activity
Members
Labels
Plan
Wiki
Code
Merge requests
0
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Debian Blends Team
blends
Commits
dc702a0a
Commit
dc702a0a
authored
6 years ago
by
Ole Streicher
Browse files
Options
Downloads
Patches
Plain Diff
Improve program output
parent
96643c65
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
devtools/blend-gen-control
+22
-9
22 additions, 9 deletions
devtools/blend-gen-control
with
22 additions
and
9 deletions
devtools/blend-gen-control
+
22
−
9
View file @
dc702a0a
...
...
@@ -92,23 +92,26 @@ if args.udd:
else
:
blend
+=
aptcache
(
args
.
release
,
[
args
.
dir
,
'
/etc/blends
'
])
missing
=
blend
.
fix_dependencies
()
missing
=
sorted
(
set
(
d
.
name
for
d
in
blend
.
fix_dependencies
()))
wanted
=
sorted
(
set
(
d
.
name
for
d
in
itertools
.
chain
(
*
(
itertools
.
chain
(
*
(
t
.
recommends
+
t
.
dependencies
))
for
t
in
blend
.
tasks
))))
if
args
.
suppressempty
:
for
task
in
blend
.
tasks
[:]:
if
len
(
task
.
recommends
)
==
0
and
len
(
task
.
dependencies
)
==
0
:
blend
.
tasks
.
remove
(
task
)
if
missing
and
args
.
missing
:
missing
=
sorted
(
set
(
d
.
name
for
d
in
missing
))
print
(
'
Missing {} packages downgraded to `suggests`:
\n
'
.
format
(
len
(
missing
))
+
'
\n
'
.
join
(
missing
))
if
missing
:
if
args
.
missing
:
print
(
'
Downgraded {} missing packages to Suggests:
\n
'
.
format
(
len
(
missing
))
+
'
\n
'
.
join
(
missing
))
else
:
print
(
'
Downgraded {} missing packages to Suggests
'
.
format
(
len
(
missing
)))
if
args
.
wanted
:
wanted
=
sorted
(
set
(
d
.
name
for
d
in
itertools
.
chain
(
*
(
itertools
.
chain
(
*
(
t
.
recommends
+
t
.
dependencies
))
for
t
in
blend
.
tasks
))))
print
(
"
Total {} packages in Depends or Recommend:
\n
"
.
format
(
len
(
wanted
))
+
'
\n
'
.
join
(
wanted
))
...
...
@@ -117,10 +120,20 @@ if args.gencontrol:
with
open
(
os
.
path
.
join
(
args
.
dir
,
'
debian
'
,
'
control
'
),
'
w
'
)
as
fp
:
fp
.
write
(
'
# This file is autogenerated. Do not edit!
\n
'
)
blend
.
gen_control
().
dump
(
fp
,
text_mode
=
True
)
print
(
"
Generated {} for {} with {} using {} Depends+Recommends
"
.
format
(
'
debian/control
'
,
args
.
release
,
'
udd
'
if
args
.
udd
else
'
apt
'
,
len
(
wanted
)))
if
args
.
taskdesc
:
with
open
(
os
.
path
.
join
(
args
.
dir
,
'
{}-tasks.desc
'
.
format
(
blend
.
name
)),
'
w
'
)
as
fp
:
blend
.
gen_task_desc
(
udeb
=
args
.
udebs
).
dump
(
fp
,
text_mode
=
True
)
print
(
"
Generated {} for {} with {} using {} Depends+Recommends
"
.
format
(
'
debian/control
'
,
args
.
release
,
'
udd
'
if
args
.
udd
else
'
apt
'
,
len
(
wanted
)))
upgraded_tasks
=
list
(
filter
(
lambda
task
:
task
.
format_upgraded
,
blend
.
tasks
))
if
upgraded_tasks
:
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment