Skip to content
Snippets Groups Projects
Commit 79475c3c authored by Michael R. Crusoe's avatar Michael R. Crusoe :gay_pride_flag: Committed by Julian Gilbey
Browse files

Import Debian changes 0.6.2-2.3

docopt (0.6.2-2.3) unstable; urgency=medium
.
  * Non-maintainer upload.
  * debian/patches/pytest6: fix FTBFS with Pytest 6. Closes: #979285
  * debian/control: add explicit build-deps on the dh-addons used.
parent a0f78685
No related branches found
Tags debian/0.6.2-2.3
No related merge requests found
Pipeline #636370 failed
docopt (0.6.2-2.3) unstable; urgency=medium
* Non-maintainer upload.
* debian/patches/pytest6: fix FTBFS with Pytest 6. Closes: #979285
* debian/control: add explicit build-deps on the dh-addons used.
-- Michael R. Crusoe <crusoe@debian.org> Sat, 23 Jan 2021 13:21:57 +0100
docopt (0.6.2-2.2) unstable; urgency=medium
* Non-maintainer upload.
......@@ -13,10 +21,10 @@ docopt (0.6.2-2.1) unstable; urgency=medium
[ Ondřej Nový ]
* d/copyright: Use https protocol in Format field
[ Antoine Beaupré ]
* Non-maintainer upload to ship Klose's patch (Closes: #941638)
[ Michael R. Crusoe ]
* debian/patches/pytest6: fix FTBFS with Pytest 6. Closes: #979285
-- Antoine Beaupré <anarcat@debian.org> Fri, 11 Oct 2019 00:57:20 -0400
-- Ondřej Nový <onovy@debian.org> Mon, 01 Oct 2018 09:41:53 +0200
docopt (0.6.2-2) unstable; urgency=medium
......
......@@ -6,6 +6,8 @@ Build-Depends: debhelper (>= 11),
python3-all,
python3-setuptools,
dh-python,
dh-sequence-python2,
dh-sequence-python3
Standards-Version: 4.2.0
Homepage: http://docopt.org
Vcs-Git: https://salsa.debian.org/debian/docopt.git
......
From: Michael R. Crusoe <crusoe@debian.org>
Subject: fix for pytest 6.x comptability
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=979285
--- docopt.orig/conftest.py
+++ docopt/conftest.py
@@ -11,7 +11,7 @@
def pytest_collect_file(path, parent):
if path.ext == ".docopt" and path.basename.startswith("test"):
- return DocoptTestFile(path, parent)
+ return DocoptTestFile.from_parent(parent, fspath=path)
def parse_test(raw):
@@ -41,7 +41,7 @@
for name, doc, cases in parse_test(raw):
name = self.fspath.purebasename
for case in cases:
- yield DocoptTestItem("%s(%d)" % (name, index), self, doc, case)
+ yield DocoptTestItem.from_parent(self, name="%s(%d)" % (name, index), doc=doc, case=case)
index += 1
pytest6
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment