Skip to content
Snippets Groups Projects
Commit 64c8c204 authored by Michael Banck's avatar Michael Banck
Browse files

* debian/patches/fix_versioneer.patch: New patch, fixes a build error during

    setup (Closes: #1074649).
parent 7bc084f5
No related branches found
No related tags found
No related merge requests found
gau2grid (2.0.7-3) UNRELEASED; urgency=medium
[ Michael Banck ]
* debian/patches/fix_versioneer.patch: New patch, fixes a build error during
setup (Closes: #1074649).
-- Debichem Team <debichem-devel@lists.alioth.debian.org> Sat, 02 Dec 2023 18:35:08 +0100
......
--- ./versioneer.py.orig 2025-03-16 16:26:32.786130190 +0100
+++ ./versioneer.py 2025-03-16 16:26:52.249986354 +0100
@@ -339,9 +339,9 @@
# configparser.NoOptionError (if it lacks "VCS="). See the docstring at
# the top of versioneer.py for instructions on writing your setup.cfg .
setup_cfg = os.path.join(root, "setup.cfg")
- parser = configparser.SafeConfigParser()
+ parser = configparser.ConfigParser()
with open(setup_cfg, "r") as f:
- parser.readfp(f)
+ parser.read_file(f)
VCS = parser.get("versioneer", "VCS") # mandatory
def get(parser, name):
pybuild_install_fix.patch
fix_setup.py
fix_versioneer.patch
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment