Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
G
glibc
Manage
Activity
Members
Labels
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
GNU Libc Maintainers
glibc
Commits
6c823b58
Commit
6c823b58
authored
1 month ago
by
Samuel Thibault
Browse files
Options
Downloads
Patches
Plain Diff
hurd: Fix calling pthread_sigmask when no thread was created yet.
debian/patches/hurd-i386/git-pthread_sigmask_nothread.diff
parent
60977a30
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Pipeline
#827433
passed with warnings
1 month ago
Stage: provisioning
Stage: build
Stage: test
Changes
3
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
debian/changelog
+2
-0
2 additions, 0 deletions
debian/changelog
debian/patches/hurd-i386/git-pthread_sigmask_nothread.diff
+19
-0
19 additions, 0 deletions
debian/patches/hurd-i386/git-pthread_sigmask_nothread.diff
debian/patches/series
+1
-0
1 addition, 0 deletions
debian/patches/series
with
22 additions
and
0 deletions
debian/changelog
+
2
−
0
View file @
6c823b58
...
...
@@ -9,6 +9,8 @@ glibc (2.41-4) UNRELEASED; urgency=medium
[ Samuel Thibault ]
* debian/patches/hurd-i386/git-pthread_once.diff: Move pthread_once symbol
to libc, to fix bison.
* debian/patches/hurd-i386/git-pthread_sigmask_nothread.diff: Fix calling
pthread_sigmask when no thread was created yet.
-- Aurelien Jarno <aurel32@debian.org> Sat, 01 Mar 2025 23:26:33 +0100
...
...
This diff is collapsed.
Click to expand it.
debian/patches/hurd-i386/git-pthread_sigmask_nothread.diff
0 → 100644
+
19
−
0
View file @
6c823b58
Upstream 2.42 has a much more involved cleanup fix which in the end
boils down to this.
Index: glibc-upstream/sysdeps/mach/hurd/htl/pt-sigstate.c
===================================================================
--- glibc-upstream.orig/sysdeps/mach/hurd/htl/pt-sigstate.c
+++ glibc-upstream/sysdeps/mach/hurd/htl/pt-sigstate.c
@@ -36,7 +36,10 @@
__pthread_sigstate (struct __pthread *th
if (set != NULL)
new = *set;
- ss = _hurd_thread_sigstate (thread->kernel_thread);
+ if (thread == _pthread_self ())
+ ss = _hurd_self_sigstate ();
+ else
+ ss = _hurd_thread_sigstate (thread->kernel_thread);
assert (ss);
_hurd_sigstate_lock (ss);
This diff is collapsed.
Click to expand it.
debian/patches/series
+
1
−
0
View file @
6c823b58
...
...
@@ -29,6 +29,7 @@ hurd-i386/git-proc_reauth.diff
# Commited for 2.42
hurd-i386/git-mig-strncpy.diff
hurd-i386/local-pthread_once.diff
hurd-i386/git-pthread_sigmask_nothread.diff
hurd-i386/local-intr-msg-clobber.diff
hurd-i386/local-enable-ldconfig.diff
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment