Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
J
json-glib
Manage
Activity
Members
Labels
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Operate
Environments
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
GNOME
json-glib
Commits
e751b51f
Commit
e751b51f
authored
9 months ago
by
Emmanuele Bassi
Browse files
Options
Downloads
Patches
Plain Diff
ci: Add analysis phase
Run the static analysis tool from clang, and ASan.
parent
0b6860c9
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
.gitlab-ci.yml
+75
-0
75 additions, 0 deletions
.gitlab-ci.yml
doc/meson.build
+1
-1
1 addition, 1 deletion
doc/meson.build
with
76 additions
and
1 deletion
.gitlab-ci.yml
+
75
−
0
View file @
e751b51f
stages
:
-
check
-
build
-
analysis
-
docs
-
deploy
...
...
@@ -21,6 +22,29 @@ stages:
paths
:
-
"
_build/meson-logs"
.build-scan
:
script
:
-
meson setup ${MESON_EXTRA_FLAGS} --prefix /usr _scan_build .
-
ninja -C _scan_build scan-build
artifacts
:
name
:
"
json-glib-static-scan-${CI_COMMIT_REF_NAME}"
when
:
always
expire_in
:
1 week
paths
:
-
"
_scan_build/meson-logs"
.build-asan
:
script
:
-
meson setup ${MESON_EXTRA_FLAGS} -Db_sanitize=address -Db_lundef=false --prefix /usr _asan_build .
-
meson compile -C _asan_build
-
meson test -C _asan_build
artifacts
:
name
:
"
json-glib-asan-${CI_COMMIT_REF_NAME}"
when
:
always
expire_in
:
1 week
paths
:
-
"
_asan_build/meson-logs"
.fedora-build
:
image
:
fedora:39
before_script
:
...
...
@@ -112,6 +136,57 @@ fedora-latest-x86_64:
MESON_VERSION
:
"
1.2.0"
MESON_EXTRA_FLAGS
:
"
--buildtype=debug
--default-library=both
-Dwerror=true
-Dglib:werror=false
-Dintrospection=enabled
-Ddocumentation=disabled"
static-scan
:
extends
:
-
.fedora-build
-
.build-scan
stage
:
analysis
needs
:
[]
variables
:
FEDORA_DEPS
:
clang
clang-analyzer
gettext
git
glib2-devel
ninja-build
python3
python3-docutils
python3-pip
python3-wheel
redhat-rpm-config
MESON_VERSION
:
"
1.2.0"
MESON_EXTRA_FLAGS
:
"
--buildtype=debug
-Dintrospection=disabled
-Ddocumentation=disabled"
CC
:
clang
allow_failure
:
true
# Run tests with the address sanitizer. We need to turn off introspection,
# since it is incompatible with asan
asan-debug-build
:
extends
:
-
.fedora-build
-
.build-asan
tags
:
[
asan
]
stage
:
analysis
needs
:
[]
variables
:
FEDORA_DEPS
:
clang
gettext
git
glib2-devel
libasan
ninja-build
python3
python3-docutils
python3-pip
python3-wheel
redhat-rpm-config
MESON_VERSION
:
"
1.2.0"
MESON_EXTRA_FLAGS
:
"
--buildtype=debug
-Dintrospection=disabled
-Ddocumentation=disabled"
CC
:
clang
allow_failure
:
true
reference
:
stage
:
docs
needs
:
[]
...
...
This diff is collapsed.
Click to expand it.
doc/meson.build
+
1
−
1
View file @
e751b51f
...
...
@@ -48,7 +48,7 @@ if get_option('man') and rst2man.found()
endforeach
endif
if
build_doc
if
build_doc
and
gidocgen
.
found
()
json_docdir
=
json_datadir
/
'doc'
toml_conf
=
configuration_data
()
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment