Skip to content
Snippets Groups Projects
Commit 7dd07f6d authored by Roger Shimizu's avatar Roger Shimizu
Browse files

debian/control: Update Build-Depends on golang-check.v1-dev

Update Build-Depends on golang-check.v1-dev instead of
golang-gocheck-dev which is already non-active upstream.

Closes: #857923
parent 22981736
No related branches found
No related tags found
No related merge requests found
golang-go-dbus (1~bzr20150122-2) UNRELEASED; urgency=medium golang-go-dbus (1~bzr20150122-2) UNRELEASED; urgency=medium
* Team upload. * Team upload.
[ Paul Tagliamonte ]
* Use a secure transport for the Vcs-Git and Vcs-Browser URL * Use a secure transport for the Vcs-Git and Vcs-Browser URL
[ Roger Shimizu ]
* debian/control:
- Update Build-Depends on golang-check.v1-dev, instead of
golang-gocheck-dev which is already non-active upstream.
* debian/patches:
- Add a patch to use golang-check.v1-dev (Closes: #857923).
-- Paul Tagliamonte <paultag@debian.org> Wed, 29 Jun 2016 20:43:06 -0400 -- Paul Tagliamonte <paultag@debian.org> Wed, 29 Jun 2016 20:43:06 -0400
golang-go-dbus (1~bzr20150122-1) unstable; urgency=medium golang-go-dbus (1~bzr20150122-1) unstable; urgency=medium
......
...@@ -6,7 +6,7 @@ Build-Depends: ...@@ -6,7 +6,7 @@ Build-Depends:
debhelper (>= 9), debhelper (>= 9),
dh-golang, dh-golang,
golang-go, golang-go,
golang-gocheck-dev, golang-check.v1-dev
Standards-Version: 3.9.5 Standards-Version: 3.9.5
Homepage: http://launchpad.net/go-dbus Homepage: http://launchpad.net/go-dbus
Vcs-Git: https://anonscm.debian.org/git/pkg-go/packages/golang-go-dbus.git Vcs-Git: https://anonscm.debian.org/git/pkg-go/packages/golang-go-dbus.git
......
From: Roger Shimizu <rogershimizu@gmail.com>
Date: Sat, 1 Apr 2017 19:33:32 +0900
Subject: use golang-check.v1-dev
---
auth_test.go | 2 +-
dbus_test.go | 2 +-
decoder_test.go | 2 +-
encoder_test.go | 2 +-
introspect_test.go | 2 +-
matchrule_test.go | 2 +-
message_test.go | 2 +-
names_test.go | 2 +-
signal_test.go | 2 +-
suite_test.go | 2 +-
transport_test.go | 2 +-
types_test.go | 2 +-
12 files changed, 12 insertions(+), 12 deletions(-)
diff --git a/auth_test.go b/auth_test.go
index 58ff52d..b59a5f8 100644
--- a/auth_test.go
+++ b/auth_test.go
@@ -2,7 +2,7 @@ package dbus
import (
"bufio"
- . "launchpad.net/gocheck"
+ . "gopkg.in/check.v1"
"net"
)
diff --git a/dbus_test.go b/dbus_test.go
index d8be5f1..6a59a75 100644
--- a/dbus_test.go
+++ b/dbus_test.go
@@ -2,7 +2,7 @@ package dbus
import (
"fmt"
- . "launchpad.net/gocheck"
+ . "gopkg.in/check.v1"
)
type callTest struct {
diff --git a/decoder_test.go b/decoder_test.go
index 034dab4..2d95f2b 100644
--- a/decoder_test.go
+++ b/decoder_test.go
@@ -1,7 +1,7 @@
package dbus
import "encoding/binary"
-import . "launchpad.net/gocheck"
+import . "gopkg.in/check.v1"
func (s *S) TestDecoderDecodeByte(c *C) {
dec := newDecoder("yy", []byte{42, 100}, binary.LittleEndian)
diff --git a/encoder_test.go b/encoder_test.go
index 3c086d4..14ea7cf 100644
--- a/encoder_test.go
+++ b/encoder_test.go
@@ -2,7 +2,7 @@ package dbus
import (
"encoding/binary"
- . "launchpad.net/gocheck"
+ . "gopkg.in/check.v1"
)
func (s *S) TestEncoderAlign(c *C) {
diff --git a/introspect_test.go b/introspect_test.go
index 03b9ecb..ff0548c 100644
--- a/introspect_test.go
+++ b/introspect_test.go
@@ -3,7 +3,7 @@
package dbus
import (
- . "launchpad.net/gocheck"
+ . "gopkg.in/check.v1"
)
var introStr = `
diff --git a/matchrule_test.go b/matchrule_test.go
index 2cda875..61d3595 100644
--- a/matchrule_test.go
+++ b/matchrule_test.go
@@ -1,6 +1,6 @@
package dbus
-import . "launchpad.net/gocheck"
+import . "gopkg.in/check.v1"
func (s *S) TestMatchRuleToString(c *C) {
mr := MatchRule{
diff --git a/message_test.go b/message_test.go
index a03e330..a706106 100644
--- a/message_test.go
+++ b/message_test.go
@@ -3,7 +3,7 @@ package dbus
import (
"bytes"
"io"
- . "launchpad.net/gocheck"
+ . "gopkg.in/check.v1"
)
var testMessage = []byte{
diff --git a/names_test.go b/names_test.go
index 8eec714..52df342 100644
--- a/names_test.go
+++ b/names_test.go
@@ -1,7 +1,7 @@
package dbus
import (
- . "launchpad.net/gocheck"
+ . "gopkg.in/check.v1"
)
func (s *S) TestConnectionWatchName(c *C) {
diff --git a/signal_test.go b/signal_test.go
index 3ed872d..ffaa4fc 100644
--- a/signal_test.go
+++ b/signal_test.go
@@ -1,7 +1,7 @@
package dbus
import (
- . "launchpad.net/gocheck"
+ . "gopkg.in/check.v1"
)
func (s *S) TestConnectionWatchSignal(c *C) {
diff --git a/suite_test.go b/suite_test.go
index 4ec381d..534c9ce 100644
--- a/suite_test.go
+++ b/suite_test.go
@@ -1,7 +1,7 @@
package dbus
import (
- . "launchpad.net/gocheck"
+ . "gopkg.in/check.v1"
"testing"
)
diff --git a/transport_test.go b/transport_test.go
index 2ac9891..ba4d63c 100644
--- a/transport_test.go
+++ b/transport_test.go
@@ -5,7 +5,7 @@ import (
"errors"
"fmt"
"io/ioutil"
- . "launchpad.net/gocheck"
+ . "gopkg.in/check.v1"
"net"
"path"
)
diff --git a/types_test.go b/types_test.go
index d358c59..4a89b7d 100644
--- a/types_test.go
+++ b/types_test.go
@@ -1,6 +1,6 @@
package dbus
-import . "launchpad.net/gocheck"
+import . "gopkg.in/check.v1"
func (s *S) TestSignatureNextType(c *C) {
// NextType() works for basic types
0001-use-golang-check.v1-dev.patch
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment