Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
J
junit4
Manage
Activity
Members
Labels
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Deploy
Releases
Container Registry
Model registry
Analyze
Value stream analytics
Contributor analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Debian Java Maintainers
junit4
Commits
0185dbc7
Commit
0185dbc7
authored
2 years ago
by
Emmanuel Bourg
Browse files
Options
Downloads
Patches
Plain Diff
Fixed the build failure with Hamcrest 2.x
parent
2264212b
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
debian/changelog
+1
-0
1 addition, 0 deletions
debian/changelog
debian/patches/hamcrest-compatibility.patch
+24
-0
24 additions, 0 deletions
debian/patches/hamcrest-compatibility.patch
debian/patches/series
+1
-0
1 addition, 0 deletions
debian/patches/series
with
26 additions
and
0 deletions
debian/changelog
+
1
−
0
View file @
0185dbc7
junit4 (4.13.2-2) UNRELEASED; urgency=medium
* Fixed the build failure with Hamcrest 2.x
* Removed the dependency on libhamcrest-java-doc
-- Emmanuel Bourg <ebourg@apache.org> Wed, 28 Sep 2022 09:09:25 +0200
...
...
This diff is collapsed.
Click to expand it.
debian/patches/hamcrest-compatibility.patch
0 → 100644
+
24
−
0
View file @
0185dbc7
Description: Fixes the compatibility with the version of Hamcrest in Debian
Author: Emmanuel Bourg <ebourg@apache.org>
Forwarded: not-needed
--- a/src/main/java/org/junit/matchers/JUnitMatchers.java
+++ b/src/main/java/org/junit/matchers/JUnitMatchers.java
@@ -57,7 +57,7 @@
*/
@Deprecated
public static <T> Matcher<Iterable<T>> everyItem(final Matcher<T> elementMatcher) {
- return CoreMatchers.everyItem(elementMatcher);
+ return CoreMatchers.everyItem((Matcher) elementMatcher);
}
/**
--- a/src/test/java/org/junit/tests/experimental/theories/runner/WithDataPointMethod.java
+++ b/src/test/java/org/junit/tests/experimental/theories/runner/WithDataPointMethod.java
@@ -109,6 +109,6 @@
}
private Matcher<Iterable<Failure>> empty() {
- return everyItem(nullValue(Failure.class));
+ return everyItem((Matcher) nullValue(Failure.class));
}
}
This diff is collapsed.
Click to expand it.
debian/patches/series
+
1
−
0
View file @
0185dbc7
exclude-dependency-sources.patch
Version.patch
java17-compatibility.patch
hamcrest-compatibility.patch
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment