Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
L
libjna-java
Manage
Activity
Members
Labels
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Deploy
Releases
Container Registry
Model registry
Analyze
Value stream analytics
Contributor analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Debian Java Maintainers
libjna-java
Commits
c09ec0d4
Commit
c09ec0d4
authored
4 years ago
by
Dimitri Ledkov
Committed by
Emmanuel Bourg
4 years ago
Browse files
Options
Downloads
Patches
Plain Diff
Fix FTBFS with gcc-10 due to warning that cannot be checked correctly (Closes: #966889)
parent
870ad0e0
No related branches found
Branches containing commit
Tags
debian/5.5.0-1.1
Tags containing commit
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
debian/changelog
+8
-0
8 additions, 0 deletions
debian/changelog
debian/patches/96c5df1d4d5985b31ddd8d5953d849ab64002f1d.patch
+48
-0
48 additions, 0 deletions
...an/patches/96c5df1d4d5985b31ddd8d5953d849ab64002f1d.patch
debian/patches/series
+1
-0
1 addition, 0 deletions
debian/patches/series
with
57 additions
and
0 deletions
debian/changelog
+
8
−
0
View file @
c09ec0d4
libjna-java (5.5.0-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix FTBFS with gcc-10 due to warning that cannot be checked
correctly. Closes: #966889
-- Dimitri John Ledkov <xnox@ubuntu.com> Mon, 24 Aug 2020 11:53:52 +0100
libjna-java (5.5.0-1) unstable; urgency=medium
* Team upload.
...
...
This diff is collapsed.
Click to expand it.
debian/patches/96c5df1d4d5985b31ddd8d5953d849ab64002f1d.patch
0 → 100644
+
48
−
0
View file @
c09ec0d4
From 96c5df1d4d5985b31ddd8d5953d849ab64002f1d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Matthias=20Bl=C3=A4sing?= <mblaesing@doppel-helix.eu>
Date: Sun, 9 Aug 2020 13:08:06 +0200
Subject: [PATCH] Fix build error on GCC 10 caused by alloca bound warnings
Since GCC 10 warnings for unbounded alloca calls are turned on by
default. The size of the allocation comes from the java side of the
bindings and thus appears to be unchecked on the native side.
---
CHANGES.md | 2 +-
native/Makefile | 10 ++++++++--
2 files changed, 9 insertions(+), 3 deletions(-)
Index: libjna-java-5.5.0/native/Makefile
===================================================================
--- libjna-java-5.5.0.orig/native/Makefile
+++ libjna-java-5.5.0/native/Makefile
@@ -321,7 +321,7 @@
endif
endif
# CC_OPTS only applied to objects build for jnidispatch, not for libffi
-# -Wno-unknown-warning-option
+# -Wno-unknown-warning-option
# => Suppress warning for unknown warnings
# -Werror => Treat warnings as errors
# -Wno-clobbered => Silence GCC warning about clobbered automatic variables.
@@ -329,6 +329,12 @@
endif
# that implements "protected" mode. In that case an exception
# is raised and the value of the potentially clobbered
# variables is ignored.
+# -Wno-alloca-larger-than => Silence warnings about unbounded alloca calls in
+# the dispatch logic. GCC tries to assert, that the size of
+# the allocated memory is bounded and thus a check for the
+# variable needs to be inplace. For the JNA case, the size
+# comes from the Java side, so checks are not visible on the
+# C side and thus can't be checked there.
#
# Enable this only on GCC versions, that can work with it. It is assumed, that
# GCC version 4.X is the lower bound. That version is problematic, as it
@@ -337,7 +343,7 @@
ifeq ($(CC),gcc)
GCC_MAJOR_VERSION = $(shell gcc -dumpversion | cut -f 1 -d '.')
ifneq ($(GCC_MAJOR_VERSION),4)
ifneq ($(GCC_MAJOR_VERSION),3)
- LOC_CC_OPTS=-Wno-unknown-warning-option -Werror -Wno-clobbered -Wno-unused-variable
+ LOC_CC_OPTS=-Wno-unknown-warning-option -Werror -Wno-clobbered -Wno-unused-variable -Wno-alloca-larger-than
endif
endif
else
This diff is collapsed.
Click to expand it.
debian/patches/series
+
1
−
0
View file @
c09ec0d4
...
...
@@ -5,3 +5,4 @@
10-disable-full-jar.patch
14-rename-native-library.patch
18-build-directory-in-soname.patch
96c5df1d4d5985b31ddd8d5953d849ab64002f1d.patch
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment