Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
N
node-d3-random
Manage
Activity
Members
Labels
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Debian JavaScript Maintainers
node-d3-random
Commits
0ea3ff7a
Commit
0ea3ff7a
authored
5 years ago
by
Nilesh Patra
Browse files
Options
Downloads
Patches
Plain Diff
Install relevant directories, swithc to rollup, clean redundant ones
parent
85050aa8
No related branches found
No related tags found
No related merge requests found
Changes
4
Hide whitespace changes
Inline
Side-by-side
Showing
4 changed files
debian/clean
+1
-0
1 addition, 0 deletions
debian/clean
debian/install
+3
-1
3 additions, 1 deletion
debian/install
debian/rules
+3
-11
3 additions, 11 deletions
debian/rules
debian/webpack.config.js
+0
-16
0 additions, 16 deletions
debian/webpack.config.js
with
7 additions
and
28 deletions
debian/clean
0 → 100644
+
1
−
0
View file @
0ea3ff7a
dist/*
This diff is collapsed.
Click to expand it.
debian/install
+
3
−
1
View file @
0ea3ff7a
build usr/lib/nodejs/d3-random/
package.json usr/lib/nodejs/d3-random/
src usr/lib/nodejs/d3-random/
dist usr/lib/nodejs/d3-random/
This diff is collapsed.
Click to expand it.
debian/rules
+
3
−
11
View file @
0ea3ff7a
...
...
@@ -5,16 +5,8 @@
#export DH_VERBOSE=1
%
:
dh
$@
dh
$@
--with
nodejs
override_dh_auto_build
:
webpack
--config
debian/webpack.config.js
\
--output-library
=
d3
\
index.js build/d3-random.js
override_dh_auto_test
:
tape
'test/**/*.js'
override_dh_auto_clean
:
rm
-rf
build
dh_auto_clean
rollup
-c
uglifyjs.terser dist/d3-random.js
-o
dist/d3-random.min.js
This diff is collapsed.
Click to expand it.
debian/webpack.config.js
deleted
100644 → 0
+
0
−
16
View file @
85050aa8
'
use strict
'
;
var
path
=
require
(
'
path
'
);
var
config
=
{
target
:
'
web
'
,
resolve
:
{
modules
:
[
'
/usr/lib/nodejs
'
,
'
.
'
],
},
resolveLoader
:
{
modules
:
[
'
/usr/lib/nodejs
'
],
},
output
:
{
libraryTarget
:
'
umd
'
},
module
:
{
rules
:
[
{
test
:
/
\.
js$/
,
loader
:
'
babel-loader
'
,
options
:
{
presets
:
[
'
es2015
'
],
plugins
:
[
'
add-module-exports
'
]
}
}]
}
}
module
.
exports
=
config
;
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment