Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
K
kodi
Manage
Activity
Members
Labels
Plan
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Debian Multimedia Team
kodi
kodi
Commits
19ae0859
Verified
Commit
19ae0859
authored
3 months ago
by
Vasyl Gello
Browse files
Options
Downloads
Patches
Plain Diff
Add workaround for swig FTBFS (Closes: #1091112)
Signed-off-by:
Vasyl Gello
<
vasek.gello@gmail.com
>
parent
010b0de8
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
debian/patches/series
+1
-0
1 addition, 0 deletions
debian/patches/series
debian/patches/workarounds/0007-pr26163-swig.patch
+28
-0
28 additions, 0 deletions
debian/patches/workarounds/0007-pr26163-swig.patch
with
29 additions
and
0 deletions
debian/patches/series
+
1
−
0
View file @
19ae0859
...
...
@@ -26,3 +26,4 @@ workarounds/0003-pcre2.patch
workarounds/0004-ffmpeg7.patch
workarounds/0005-pr25830-upnp.patch
workarounds/0006-pr25931-opengl.patch
workarounds/0007-pr26163-swig.patch
This diff is collapsed.
Click to expand it.
debian/patches/workarounds/0007-pr26163-swig.patch
0 → 100644
+
28
−
0
View file @
19ae0859
From 7fa890495b6169692a5dd4c7f0136f8c05006812 Mon Sep 17 00:00:00 2001
From: Rudi Heitbaum <rudi@heitbaum.com>
Date: Mon, 21 Oct 2024 22:10:29 +1100
Subject: [PATCH] [swig] Fix building with swig 4.3.0
swig 4.3.0 has dropped the -xmllang option used with -xml, which had no effect on the output.
Ref:
- https://github.com/swig/swig/commit/86498e46c6a6218a3d091c12513c40076ac2ce63
Signed-off-by: Rudi Heitbaum <rudi@heitbaum.com>
---
xbmc/interfaces/swig/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/xbmc/interfaces/swig/CMakeLists.txt b/xbmc/interfaces/swig/CMakeLists.txt
index 0d0cadcabd524..ac610163f7f86 100644
--- a/xbmc/interfaces/swig/CMakeLists.txt
+++ b/xbmc/interfaces/swig/CMakeLists.txt
@@ -22,7 +22,7 @@
function(generate_file file)
add_custom_command(OUTPUT ${CPP_FILE}
COMMAND ${SWIG_EXECUTABLE}
- ARGS -w401 -c++ -o ${file}.xml -xml -I${CMAKE_SOURCE_DIR}/xbmc -xmllang python ${CMAKE_CURRENT_SOURCE_DIR}/../swig/${file}
+ ARGS -w401 -c++ -o ${file}.xml -xml -I${CMAKE_SOURCE_DIR}/xbmc ${CMAKE_CURRENT_SOURCE_DIR}/../swig/${file}
COMMAND groovy
ARGS -cp "${classpath}" ${CMAKE_SOURCE_DIR}/tools/codegenerator/Generator.groovy ${file}.xml ${CMAKE_CURRENT_SOURCE_DIR}/../python/PythonSwig.cpp.template ${file}.cpp > ${devnull}
${CLANG_FORMAT_COMMAND}
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment