Skip to content
Snippets Groups Projects
Verified Commit 19ae0859 authored by Vasyl Gello's avatar Vasyl Gello
Browse files

Add workaround for swig FTBFS (Closes: #1091112)

parent 010b0de8
No related branches found
No related tags found
No related merge requests found
......@@ -26,3 +26,4 @@ workarounds/0003-pcre2.patch
workarounds/0004-ffmpeg7.patch
workarounds/0005-pr25830-upnp.patch
workarounds/0006-pr25931-opengl.patch
workarounds/0007-pr26163-swig.patch
From 7fa890495b6169692a5dd4c7f0136f8c05006812 Mon Sep 17 00:00:00 2001
From: Rudi Heitbaum <rudi@heitbaum.com>
Date: Mon, 21 Oct 2024 22:10:29 +1100
Subject: [PATCH] [swig] Fix building with swig 4.3.0
swig 4.3.0 has dropped the -xmllang option used with -xml, which had no effect on the output.
Ref:
- https://github.com/swig/swig/commit/86498e46c6a6218a3d091c12513c40076ac2ce63
Signed-off-by: Rudi Heitbaum <rudi@heitbaum.com>
---
xbmc/interfaces/swig/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/xbmc/interfaces/swig/CMakeLists.txt b/xbmc/interfaces/swig/CMakeLists.txt
index 0d0cadcabd524..ac610163f7f86 100644
--- a/xbmc/interfaces/swig/CMakeLists.txt
+++ b/xbmc/interfaces/swig/CMakeLists.txt
@@ -22,7 +22,7 @@ function(generate_file file)
add_custom_command(OUTPUT ${CPP_FILE}
COMMAND ${SWIG_EXECUTABLE}
- ARGS -w401 -c++ -o ${file}.xml -xml -I${CMAKE_SOURCE_DIR}/xbmc -xmllang python ${CMAKE_CURRENT_SOURCE_DIR}/../swig/${file}
+ ARGS -w401 -c++ -o ${file}.xml -xml -I${CMAKE_SOURCE_DIR}/xbmc ${CMAKE_CURRENT_SOURCE_DIR}/../swig/${file}
COMMAND groovy
ARGS -cp "${classpath}" ${CMAKE_SOURCE_DIR}/tools/codegenerator/Generator.groovy ${file}.xml ${CMAKE_CURRENT_SOURCE_DIR}/../python/PythonSwig.cpp.template ${file}.cpp > ${devnull}
${CLANG_FORMAT_COMMAND}
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment