Skip to content
Snippets Groups Projects
Commit fb38121a authored by Marcos Fouces's avatar Marcos Fouces
Browse files

Add 37_fix-lib-and-share-dirs.patch (Closes: #919631).

parent d16b2425
No related branches found
Tags debian/3.0.4+dfsg-2
No related merge requests found
Pipeline #129017 failed
......@@ -13,6 +13,7 @@ dsniff (2.4b1+debian-30) UNRELEASED; urgency=medium
* Bump to debhelper-compat 12.
* Add Rules-Requires-Root: no in control file.
* Bump to Standards-Version 4.5.0
* Add 37_fix-lib-and-share-dirs.patch (Closes: #919631).
-- Marcos Fouces <marcos.fouces@gmail.com> Thu, 23 Apr 2020 10:18:57 +0200
......
Description: Fix directory location for data files. They were wrongly set to lib dirs.
Author: Hank Leininger <hlein@korelogic.com>
--- a/Makefile.in
+++ b/Makefile.in
@@ -11,12 +11,12 @@
install_prefix =
prefix = @prefix@
exec_prefix = @exec_prefix@
-libdir = @libdir@
+sharedir = $(prefix)/share/dsniff
sbindir = @sbindir@
mandir = @mandir@
CC = @CC@
-CFLAGS = @CFLAGS@ -DDSNIFF_LIBDIR=\"$(libdir)/\"
+CFLAGS = @CFLAGS@ -DDSNIFF_LIBDIR=\"$(sharedir)/\"
CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
@@ -157,10 +157,10 @@
for file in $(PROGS); do \
$(INSTALL_PROGRAM) -m 755 $$file $(install_prefix)$(sbindir); \
done
- test -d $(install_prefix)$(libdir) || \
- $(INSTALL) -d $(install_prefix)$(libdir)
+ test -d $(install_prefix)$(sharedir) || \
+ $(INSTALL) -d $(install_prefix)$(sharedir)
for file in $(CONFIGS); do \
- $(INSTALL_DATA) $$file $(install_prefix)$(libdir); \
+ $(INSTALL_DATA) $$file $(install_prefix)$(sharedir); \
done
test -d $(install_prefix)$(mandir)/man8 || \
$(INSTALL) -d $(install_prefix)$(mandir)/man8
......@@ -34,3 +34,4 @@
34_fix-parallel-FTBFS.patch
35_Add_CPPFLAGS.patch
36_implicit_declarations.patch
37_fix-lib-and-share-dirs.patch
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment