Skip to content
Snippets Groups Projects
Commit 6b2eb6c6 authored by Colin Watson's avatar Colin Watson
Browse files

Fix installation of alembic.ini

As hinted in https://github.com/jupyterhub/jupyterhub/issues/4593,
build-depend on python3-setuptools-scm rather than adding alembic.ini
incorrectly to `data_files` (it should have been a tuple of the path to
install to and a list of files; but this approach is easier).

Closes: #1100077
parent 249e7b5c
No related branches found
No related tags found
No related merge requests found
jupyterhub (5.2.1+ds1-2) UNRELEASED; urgency=medium
* Build-depend on python3-setuptools-scm rather than adding alembic.ini
incorrectly to data_files (closes: #1100077).
-- Colin Watson <cjwatson@debian.org> Sun, 16 Mar 2025 16:33:28 +0000
jupyterhub (5.2.1+ds1-1) unstable; urgency=medium jupyterhub (5.2.1+ds1-1) unstable; urgency=medium
* New upstream release. * New upstream release.
......
...@@ -27,6 +27,7 @@ Build-Depends: ...@@ -27,6 +27,7 @@ Build-Depends:
python3-requests, python3-requests,
python3-requests-mock, python3-requests-mock,
python3-setuptools, python3-setuptools,
python3-setuptools-scm,
python3-tornado, python3-tornado,
python3-traitlets, python3-traitlets,
# Testsuite: autopkgtest-pkg-pybuild # Testsuite: autopkgtest-pkg-pybuild
......
From: Roland Mas <lolando@debian.org>
Date: Sun, 29 Sep 2024 16:17:01 +0200
Subject: Include alembic.ini
---
setup.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
index 736f958..439eb92 100755
--- a/setup.py
+++ b/setup.py
@@ -270,7 +270,7 @@ cmdclass = {
def main():
setup(
cmdclass=cmdclass,
- data_files=get_data_files(),
+ data_files=["jupyterhub/alembic.ini"] + get_data_files(),
)
0001-Add-empty-config-file.patch 0001-Add-empty-config-file.patch
0002-Use-configurable-http-proxy-instead-of-Traefik.patch 0002-Use-configurable-http-proxy-instead-of-Traefik.patch
0003-Do-not-use-npm-even-if-available-during-build.patch 0003-Do-not-use-npm-even-if-available-during-build.patch
0004-Include-alembic.ini.patch
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment