Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
M
markupsafe
Manage
Activity
Members
Labels
Plan
Wiki
Code
Merge requests
0
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Debian Python Team
packages
markupsafe
Commits
9c10e0dc
Commit
9c10e0dc
authored
3 years ago
by
Thomas Goirand
Browse files
Options
Downloads
Patches
Plain Diff
Kill Python2 and dbg packages. (Closes: #994309).
parent
7dc75d42
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
debian/changelog
+1
-0
1 addition, 0 deletions
debian/changelog
debian/control
+1
-52
1 addition, 52 deletions
debian/control
debian/rules
+7
-26
7 additions, 26 deletions
debian/rules
with
9 additions
and
78 deletions
debian/changelog
+
1
−
0
View file @
9c10e0dc
...
...
@@ -17,6 +17,7 @@ markupsafe (2.0.1-1) experimental; urgency=medium
* New upstream release.
* Ran wrap-and-sort -bastk.
* Removed useless versions in build-depends.
* Kill Python2 and dbg packages. (Closes: #994309).
-- Thomas Goirand <zigo@debian.org> Fri, 17 Sep 2021 23:27:58 +0200
...
...
This diff is collapsed.
Click to expand it.
debian/control
+
1
−
52
View file @
9c10e0dc
...
...
@@ -7,10 +7,6 @@ Uploaders:
Build-Depends:
debhelper-compat (= 12),
dh-python,
python-all-dbg,
python-all-dev,
python-setuptools,
python3-all-dbg,
python3-all-dev,
python3-setuptools,
Standards-Version: 4.5.0
...
...
@@ -18,60 +14,13 @@ Homepage: https://palletsprojects.com/p/markupsafe/
Vcs-Git: https://salsa.debian.org/python-team/packages/markupsafe.git
Vcs-Browser: https://salsa.debian.org/python-team/packages/markupsafe
Package: python-markupsafe
Architecture: any
Depends:
${misc:Depends},
${python:Depends},
${shlibs:Depends},
Provides:
${python:Provides},
Description: HTML/XHTML/XML string library for Python
MarkupSafe is a Python library implementing a unicode subclass that is
aware of HTML escaping rules. It can be used to implement automatic
string escaping.
Package: python-markupsafe-dbg
Architecture: any
Section: debug
Depends:
python-markupsafe (= ${binary:Version}),
${misc:Depends},
${python:Depends},
${shlibs:Depends},
Multi-Arch: same
Description: HTML/XHTML/XML string library for Python - debug version
MarkupSafe is a Python library implementing a unicode subclass that is
aware of HTML escaping rules. It can be used to implement automatic
string escaping.
.
This package contains the extension built for the Python debug interpreter.
Package: python3-markupsafe
Architecture: any
Depends:
${misc:Depends},
${python3:Depends},
${shlibs:Depends},
Description: HTML/XHTML/XML string library for Python 3
MarkupSafe is a Python library implementing a unicode subclass that is
aware of HTML escaping rules. It can be used to implement automatic
string escaping.
.
This package contains the Python 3 version.
Package: python3-markupsafe-dbg
Architecture: any
Section: debug
Depends:
python3-markupsafe (= ${binary:Version}),
${misc:Depends},
${python3:Depends},
${shlibs:Depends},
Multi-Arch: same
Description: HTML/XHTML/XML string library for Python 3 - debug version
Description: HTML/XHTML/XML string library
MarkupSafe is a Python library implementing a unicode subclass that is
aware of HTML escaping rules. It can be used to implement automatic
string escaping.
.
This package contains the extension built for the Python 3 debug interpreter.
This diff is collapsed.
Click to expand it.
debian/rules
+
7
−
26
View file @
9c10e0dc
#!/usr/bin/make -f
#export DH_VERBOSE=1
PYVERS=$(shell
pyversions -vr) $(shell
py3versions -vr)
PYVERS=$(shell py3versions -vr)
include /usr/share/python/python.mk
pkgdir = $(CURDIR)/debian/python
$(if $(patsubst 3.%,,$(1)),,3)
-markupsafe
include /usr/share/python
3
/python.mk
pkgdir = $(CURDIR)/debian/python
3
-markupsafe
DPKG_EXPORT_BUILDFLAGS = 1
-include /usr/share/dpkg/buildflags.mk
...
...
@@ -15,26 +15,20 @@ clean:
rm -rf dist build MarkupSafe.egg-info
find . -name '*\.pyc' -delete
dh_clean install-stamp build-arch \
$(PYVERS:%=install-python%) $(PYVERS:%=build-python%) \
$(PYVERS:%=install-debug-python%) $(PYVERS:%=build-debug-python%)
$(PYVERS:%=install-python%) $(PYVERS:%=build-python%)
build: build-arch
build-indep:
build-arch: $(PYVERS:%=build-python%)
$(PYVERS:%=build-debug-python%)
build-arch: $(PYVERS:%=build-python%)
touch $@
build-python%:
python$* setup.py build
touch $@
build-debug-python%:
python$*-dbg setup.py build
touch $@
install: install-stamp
install-stamp: $(PYVERS:%=install-python%)
$(PYVERS:%=install-debug-python%)
install-stamp: $(PYVERS:%=install-python%)
dh_install
touch $@
...
...
@@ -46,27 +40,14 @@ install-python%: build
rm -f $(call pkgdir,$*)$(call py_libdir,$*)/markupsafe/_speedups.c
touch $@
install-debug-python%: build
python$*-dbg setup.py install \
--install-layout=deb --skip-build \
--single-version-externally-managed \
--root $(call pkgdir,$*)-dbg/
touch $@
binary-arch: build install
dh_testdir
dh_testroot
dh_installchangelogs -a
dh_installdocs -a
dh_python2 -a
dh_python3 -a
dh_makeshlibs -a
dh_strip -ppython-markupsafe --dbg-package=python-markupsafe-dbg
dh_strip -ppython3-markupsafe --dbg-package=python3-markupsafe-dbg
rm -rf $(call pkgdir,2.X)-dbg/usr/share/doc/python-markupsafe-dbg
rm -rf $(call pkgdir,3.X)-dbg/usr/share/doc/python3-markupsafe-dbg
ln -s python-markupsafe $(call pkgdir,2.X)-dbg/usr/share/doc/python-markupsafe-dbg
ln -s python3-markupsafe $(call pkgdir,3.X)-dbg/usr/share/doc/python3-markupsafe-dbg
dh_strip -ppython3-markupsafe
dh_compress -a -X.py
dh_fixperms -a
dh_installdeb -a
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment