Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
P
python-django-csp
Manage
Activity
Members
Labels
Plan
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Debian Python Team
packages
python-django-csp
Commits
595a7f68
Commit
595a7f68
authored
2 years ago
by
Michael Fladischer
Browse files
Options
Downloads
Patches
Plain Diff
Add patch for Django 4 compatibility (Closes: #1013555).
parent
f580a0eb
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
debian/changelog
+6
-0
6 additions, 0 deletions
debian/changelog
debian/patches/0002-Django-4-compatibility.patch
+77
-0
77 additions, 0 deletions
debian/patches/0002-Django-4-compatibility.patch
debian/patches/series
+1
-0
1 addition, 0 deletions
debian/patches/series
with
84 additions
and
0 deletions
debian/changelog
+
6
−
0
View file @
595a7f68
python-django-csp (3.7-3) UNRELEASED; urgency=medium
* Add patch for Django 4 compatibility (Closes: #1013555).
-- Michael Fladischer <fladi@debian.org> Sat, 30 Jul 2022 18:56:57 +0000
python-django-csp (3.7-2) unstable; urgency=low
[ Debian Janitor ]
...
...
This diff is collapsed.
Click to expand it.
debian/patches/0002-Django-4-compatibility.patch
0 → 100644
+
77
−
0
View file @
595a7f68
From: Michael Fladischer <FladischerMichael@fladi.at>
Date: Sat, 30 Jul 2022 18:56:40 +0000
Subject: Django 4 compatibility.
---
csp/tests/test_context_processors.py | 2 +-
csp/tests/test_contrib.py | 2 +-
csp/tests/test_decorators.py | 2 +-
csp/tests/test_middleware.py | 2 +-
csp/tests/utils.py | 2 +-
5 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/csp/tests/test_context_processors.py b/csp/tests/test_context_processors.py
index 6c4f062..74acb59 100644
--- a/csp/tests/test_context_processors.py
+++ b/csp/tests/test_context_processors.py
@@ -5,7 +5,7 @@
from csp.middleware import CSPMiddleware
from csp.context_processors import nonce
rf = RequestFactory()
-mw = CSPMiddleware()
+mw = CSPMiddleware("")
def test_nonce_context_processor():
diff --git a/csp/tests/test_contrib.py b/csp/tests/test_contrib.py
index 33998ab..0571ba8 100644
--- a/csp/tests/test_contrib.py
+++ b/csp/tests/test_contrib.py
@@ -6,7 +6,7 @@
from csp.contrib.rate_limiting import RateLimitedCSPMiddleware
HEADER = 'Content-Security-Policy'
-mw = RateLimitedCSPMiddleware()
+mw = RateLimitedCSPMiddleware("")
rf = RequestFactory()
diff --git a/csp/tests/test_decorators.py b/csp/tests/test_decorators.py
index 6f2716e..feffd71 100644
--- a/csp/tests/test_decorators.py
+++ b/csp/tests/test_decorators.py
@@ -7,7 +7,7 @@
from csp.middleware import CSPMiddleware
REQUEST = RequestFactory().get('/')
-mw = CSPMiddleware()
+mw = CSPMiddleware("")
def test_csp_exempt():
diff --git a/csp/tests/test_middleware.py b/csp/tests/test_middleware.py
index f9413ce..2155826 100644
--- a/csp/tests/test_middleware.py
+++ b/csp/tests/test_middleware.py
@@ -10,7 +10,7 @@
from csp.middleware import CSPMiddleware
HEADER = 'Content-Security-Policy'
-mw = CSPMiddleware()
+mw = CSPMiddleware("")
rf = RequestFactory()
diff --git a/csp/tests/utils.py b/csp/tests/utils.py
index 7d7814f..59cbae4 100644
--- a/csp/tests/utils.py
+++ b/csp/tests/utils.py
@@ -5,7 +5,7 @@
from csp.middleware import CSPMiddleware
JINJA_ENV = engines['jinja2']
-mw = CSPMiddleware()
+mw = CSPMiddleware("")
rf = RequestFactory()
This diff is collapsed.
Click to expand it.
debian/patches/series
+
1
−
0
View file @
595a7f68
0001-Remove-PEP8-and-flakes-options-from-pytest-call.patch
0002-Django-4-compatibility.patch
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment