Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
P
python-django-tagging
Manage
Activity
Members
Labels
Plan
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Debian Python Team
packages
python-django-tagging
Commits
580dfcf5
Commit
580dfcf5
authored
2 years ago
by
Bas Couwenberg
Browse files
Options
Downloads
Patches
Plain Diff
Add patch to fix FTBFS with python3.11. (closes: #1028671)
parent
d4fb2d06
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
debian/changelog
+8
-0
8 additions, 0 deletions
debian/changelog
debian/patches/python3.11.patch
+24
-0
24 additions, 0 deletions
debian/patches/python3.11.patch
debian/patches/series
+1
-0
1 addition, 0 deletions
debian/patches/series
with
33 additions
and
0 deletions
debian/changelog
+
8
−
0
View file @
580dfcf5
python-django-tagging (1:0.5.0-4) UNRELEASED; urgency=medium
* Team upload.
* Add patch to fix FTBFS with python3.11.
(closes: #1028671)
-- Bas Couwenberg <sebastic@debian.org> Thu, 19 Jan 2023 17:12:18 +0100
python-django-tagging (1:0.5.0-3) unstable; urgency=medium
* Team upload
...
...
This diff is collapsed.
Click to expand it.
debian/patches/python3.11.patch
0 → 100644
+
24
−
0
View file @
580dfcf5
Description: Fix FTBFS with python3.11.
Author: Bas Couwenberg <sebastic@debian.org>
Bug-Debian: https://bugs.debian.org/1028671
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -768,7 +768,7 @@
list items of a particular model class w
from shop.apps.products.models import Widget
urlpatterns = patterns('',
- url(r'^widgets/tag/(?P<tag>[^/]+(?u))/$',
+ url(r'(?u)^widgets/tag/(?P<tag>[^/]+)/$',
TaggedObjectList.as_view(model=Widget, paginate_by=10, allow_empty=True),
name='widget_tag_detail'),
)
--- a/tagging/tests/urls.py
+++ b/tagging/tests/urls.py
@@ -16,5 +16,5 @@
urlpatterns = [
related_tags=True)),
re_path(r'^no-tag/$', TaggedObjectList.as_view(model=Article)),
re_path(r'^no-query-no-model/$', TaggedObjectList.as_view()),
- re_path(r'^(?P<tag>[^/]+(?u))/$', TaggedObjectList.as_view(model=Article)),
+ re_path(r'(?u)^(?P<tag>[^/]+)/$', TaggedObjectList.as_view(model=Article)),
]
This diff is collapsed.
Click to expand it.
debian/patches/series
+
1
−
0
View file @
580dfcf5
...
...
@@ -2,3 +2,4 @@ Use-local-inventory-for-intersphinx.patch
django-4.x-fixes/Use-smart_str-instead-of-deprecated-smart_text-Django-fun.patch
django-4.x-fixes/Use-re_path-instead-of-deprecated-url-Django-function.patch
django-4.x-fixes/Add-support-for-Django-4-compatibility.patch
python3.11.patch
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment