Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
P
python-mbed-ls
Manage
Activity
Members
Labels
Plan
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Debian Python Team
packages
python-mbed-ls
Commits
d4ad8c46
Commit
d4ad8c46
authored
2 years ago
by
Stefano Rivera
Browse files
Options
Downloads
Patches
Plain Diff
Patch: Support setuptools >= 60 (Closes: #1022538)
parent
36920890
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
debian/changelog
+6
-0
6 additions, 0 deletions
debian/changelog
debian/patches/series
+1
-0
1 addition, 0 deletions
debian/patches/series
debian/patches/setuptools-60
+36
-0
36 additions, 0 deletions
debian/patches/setuptools-60
with
43 additions
and
0 deletions
debian/changelog
+
6
−
0
View file @
d4ad8c46
python-mbed-ls (1.6.2+dfsg-8) UNRELEASED; urgency=medium
* Patch: Support setuptools >= 60 (Closes: #1022538)
-- Stefano Rivera <stefanor@debian.org> Sun, 13 Nov 2022 10:48:28 +0200
python-mbed-ls (1.6.2+dfsg-7) unstable; urgency=medium
* d/control:
...
...
This diff is collapsed.
Click to expand it.
debian/patches/series
+
1
−
0
View file @
d4ad8c46
...
...
@@ -2,3 +2,4 @@ doxygen-documentation
skip-database-tests
fix-syntaxwarnings-is-with-literals
relax-setup-py-dependency-versions
setuptools-60
This diff is collapsed.
Click to expand it.
debian/patches/setuptools-60
0 → 100644
+
36
−
0
View file @
d4ad8c46
From: Stefano Rivera <stefanor@debian.org>
Date: Sun, 13 Nov 2022 10:46:28 +0200
Subject: Import setup from setuptools
setuptools 60 uses its own bundled version of distutils, by default. It
injects this into sys.modules, at import time. So we need to make sure
that it is imported, before anything else imports distutils, to ensure
everything is using the same distutils version.
This change in setuptools is to prepare for Python 3.12, which will drop
distutils.
In this case, the best way to deal with the problem is to just use
setuptools' setup().
Bug-Debian: https://bugs.debian.org/1022538
Forwarded: https://github.com/ARMmbed/mbed-os-tools/pull/285
---
setup.py | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/setup.py b/setup.py
index eb02cd5..1fa3089 100644
--- a/setup.py
+++ b/setup.py
@@ -20,9 +20,8 @@
Author: Przemyslaw Wirkus <Przemyslaw.Wirkus@arm.com>
"""
import os
-from distutils.core import setup
from io import open
-from setuptools import find_packages
+from setuptools import find_packages, setup
DESCRIPTION = "mbed-ls is a Python module that detects and lists mbed-enabled devices connected to the host computer"
OWNER_NAMES = 'Jimmy Brisson, Brian Daniels'
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment