Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
P
python-mitogen
Manage
Activity
Members
Labels
Plan
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Debian Python Team
packages
python-mitogen
Commits
d75c6cb9
Commit
d75c6cb9
authored
1 month ago
by
Stefano Rivera
Browse files
Options
Downloads
Patches
Plain Diff
Patch: Handle the removal of ansible.parsing.utils.jsonify (Closes: #1103652)
parent
c6d641a8
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
debian/changelog
+2
-0
2 additions, 0 deletions
debian/changelog
debian/patches/replace-jsonify
+41
-0
41 additions, 0 deletions
debian/patches/replace-jsonify
debian/patches/series
+1
-0
1 addition, 0 deletions
debian/patches/series
with
44 additions
and
0 deletions
debian/changelog
+
2
−
0
View file @
d75c6cb9
python-mitogen (0.3.22-4) UNRELEASED; urgency=medium
* Forward Ansible 2.19 patches.
* Patch: Handle the removal of ansible.parsing.utils.jsonify
(Closes: #1103652)
-- Stefano Rivera <stefanor@debian.org> Sun, 20 Apr 2025 11:06:00 -0400
...
...
This diff is collapsed.
Click to expand it.
debian/patches/replace-jsonify
0 → 100644
+
41
−
0
View file @
d75c6cb9
From: Stefano Rivera <stefanor@debian.org>
Date: Sun, 20 Apr 2025 11:04:34 -0400
Subject: Handle the removal of ansible.parsing.utils.jsonify in ansible-core
2.19
Bug-Debian: https://bugs.debian.org/1103652
Bug-Upstream: https://github.com/mitogen-hq/mitogen/issues/1258
Forwarded: https://github.com/mitogen-hq/mitogen/pull/1259
---
ansible_mitogen/mixins.py | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/ansible_mitogen/mixins.py b/ansible_mitogen/mixins.py
index dadf2c1..c79bf10 100644
--- a/ansible_mitogen/mixins.py
+++ b/ansible_mitogen/mixins.py
@@ -29,6 +29,7 @@
from __future__ import absolute_import, division, print_function
__metaclass__ = type
+import json
import logging
import os
import pwd
@@ -42,7 +43,6 @@
import ansible.vars.clean
from ansible.module_utils.common.text.converters import to_bytes, to_text
from ansible.module_utils.six.moves import shlex_quote
-from ansible.parsing.utils.jsonify import jsonify
import mitogen.core
import mitogen.select
@@ -220,7 +220,7 @@
class ActionModuleMixin(ansible.plugins.action.ActionBase):
action module, and probably others.
"""
if isinstance(data, dict):
- data = jsonify(data)
+ data = json.dumps(data)
if not isinstance(data, bytes):
data = to_bytes(data, errors='surrogate_or_strict')
This diff is collapsed.
Click to expand it.
debian/patches/series
+
1
−
0
View file @
d75c6cb9
...
...
@@ -5,3 +5,4 @@ skip-django-tests
skip-python2.7-test
edit-ansible-version-restrictions
workaround-missing-strip-unsafe
replace-jsonify
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment